PDA

Показать полную графическую версию : [архив] Microsoft Excel


Страниц : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 [15] 16 17 18

XCodeR
21-07-2006, 12:26
wolland
- выделяете нужный столбец
- копируете его(Ctrl+C),
- Правка -> Специальная вставка
- Отмечаете вместо "все", "значения"
- жмете ОК

punkrat
21-07-2006, 17:57
pos2man нет этот вариант не прошел, видимо единственный выход макрорс написать, может поможет...

ShaRP
22-07-2006, 00:17
wolland

XCodeR дело говорит. "Специальная вставка - значения". Просто и быстро. А тех, кто выше - не слушай. ;)

wolland
22-07-2006, 15:34
Да, спасибо огромное, выручили, админа-неудачника, а то прайс на сайт надо выкладывать, а как от
этих колонок избавиться не знал
Еще раз огромное спасибо

praying_mantis
27-10-2006, 16:23
Допустим, есть ячейка А1 со значением "23.10.2006"
Есть ячейка А2 со значением "24.10.2006"
Подскажите, какой формулой можно получить результирующую ячейку А3 вида: "23.10.2006-24.10.2006" ?
Нужно что-нибудь вроде: =Сцепить(А1;"-";A2).
Но не работает, поскольку даты тут же превращаются в числа. :(

tolikt
27-10-2006, 17:41
=СЦЕПИТЬ(ТЕКСТ(A1;"ДД.ММ.ГГ");"-";ТЕКСТ(A2;"ДД.ММ.ГГ"))

a_axe
27-10-2006, 17:43
=A1&"-"&A2

praying_mantis
30-10-2006, 09:17
Спасибо, tolikt. То что надо! :)

Gary Potter
20-12-2006, 18:56
Работаю в Exсel. Хочу узнать что-то новое и поделится опытом :beer:
кто знает формулу. чтоб считала "названия"?
например: столбец состоит из знаков "а,а,а,а,в,в,р,а,с,к,м, и т.д.
мне нужна формула, которая считала б количество например только "а",следующая только "р" ну и т.д.

Coutty
21-12-2006, 17:33
Gary Potter, как я понял, исходные данные: столбец / строка / массив данных, где в каждой ячейке есть 1 или несколько символов. Нужно посчитать количество ячеек с заданным значением. Так?

=СЧЁТЕСЛИ(A1:A15;"у")
А1:А15 - диапазон, в котором надо считать.
у - то, что нужно считать.

Gary Potter
22-12-2006, 12:11
Вопрос второй: а существует формула, которая еще и считала б суму значений напротив даных выборочных значений?

Coutty
22-12-2006, 19:26
Gary Potter, отвечаю прямо: существует.
Полагаю, возникает вопрос №3: что за формула?))

Ну, может, у меня не очень красивое решение получилось, но оно работает.
1. Забиваем на функцию "СЧЁТЕСЛИ". Она не понадобится.
2. Первый столбец (скажем, A1:A20) состоит из букв, которые надо считать.
3. Во втором столбце есть некоторые числа, которые соответствуют каждой отдельной строке (возможно, это количество штук).
4. Ниже делаем ячейку, в которую будет вводится искомое значение (Скажем, ячейка B24).
5. В третьем столбце (C) пишем формулу: =ЕСЛИ(A1=$B$24; B1; "-"). Объясняю: Если значение в первом столбце соответствует искомому (введённому в B24), то в ячейку с этой формулой (в данном случае - C1) копируется значение из ячейки соседнего столбца (который соответствует количеству штук - B1). Если же в 1 столбце что-то "левое", то ставится прочерк. Знаки доллара у $B$24 показывают, что при растягивании формулы по столбцу, эта ячейка не будет изменятся (можно нажать F4, для получения этих баксов).
Таким образом получаем столбец, в который скопированы "штуки", соответствующие только нужному "товару".
Далее - легко. Суммируем.
Скажем, в ячейку B25 пишем =СУММ(C1:C20).

Если объяснил недоходчиво, то см. прикреплённый файл (Ехелевская таблица 2003 г.в., WinRAR 3.61)

Gary Potter
25-12-2006, 15:03
Coutty Большое спасибо! Для начала подходит, только это рутина при моем объеме работы. (не в обиду). А эсли формулу модифицировать скажем так: =ЕСЛИ(ИЛИ(A1:A20)=$B$24; ИЛИ(B1:B20); "-") или так =СУММ(ЕСЛИ(ИЛИ(A1:A20)=$B$24; ИЛИ(B1:B20); "-")) т.е. вместо одного значения задать диапазон и сразу посчитать суму. пока не работает. может можно как нибуть подправить?

Coutty
25-12-2006, 17:52
Gary Potter, блин, задачка... :sorry:
Попробуйте написать сценарий (Ага, издеваюсь). Т.к. там всё на Visual Basic'e кодируется, я помочь не могу (Проблема не только в том, что я VB не знаю. Проблема ещё в незнании объектной модели ехеля. Справка очень туманная...).

Gary Potter
26-12-2006, 13:06
я тут сделал маааленький пример таблици, в которой мне нужна вышеуказаная формула... может что то можна сделать?

Coutty
26-12-2006, 14:45
Gary Potter, поясни табличку.
Я ничего не понял (кстати, можно было и по-русски написать - а то глаз режет)
Стрелочка с комментарием указывает на стык линий.
Что требуется - непонятно.

Gary Potter
26-12-2006, 15:05
.....а я не писал, а скопировал давно написаное. а "коментарий" - это примечание на ячейку в предпоследнем столбце таблици (M15), т.е.: 1-я формула (столбец L) считает количество "названий" (столбец С (по твоей формуле)). Теперь нужно чтоб в столбце M считало суму по определенним названиям (столбец С) из столбца G (ГЫ)

Coutty
26-12-2006, 19:03
Gary Potter, ну я ж говорю - VBScript. А я в нём не силён (настоящий кот не обязан знать VisualBarsik =^_^= ).
Спроси в подфоруме "Программирование".

Требуется примерно следующее:

ДляКаждойСтроки (n от 12 до 57) {
ОбнулитьПеременную (Сумма);
ПросмотрВсехЯчеекC[m] (m от 11 до 25) {
Если (C[m] == K[n]) {
Сумма += ЗначениеИзG[m];
}
M[n] = Сумма;
}

Gary Potter
28-12-2006, 09:38
У меня новый бредовый вопрос! Циклическая ссилка, почему результат всегда = 0? Бывают ли формулы "накопления сумы"? (наверное выразился не правильно) Например: есть некая ячейка А1, которая = ячейке В1, а эта ячейка (В1) равна А1+С1. Sorry!У меня утром всегда пробивает на такого рода бред. (Аможет и не бред?)

a_axe
28-12-2006, 19:10
Речь идет об итерациях. Для русского офиса меню сервис -> параметры-> вкладка "вычисления" , отмечаете галкой "разрешить итерации", в окошке выставляете предельное число повторений.




© OSzone.net 2001-2012