Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 2000/XP/2003 » Вопросы По WPI

Ответить
Настройки темы
Вопросы По WPI

Аватара для DenchikK

Старожил


Сообщения: 268
Благодарности: 40

Профиль | Отправить PM | Цитировать


Изменения
Автор: Petya V4sechkin
Дата: 10-02-2014




Windows Post Install Wizard (WPI)
Официальный сайт WPI
Официальный форум WPI на MSFN.org

Обзор WPI в статье "Выбор устанавливаемых приложений" (там рассказ о старой версии, но кое-что почерпнуть можно)

Для тех кто в танке: WPI не волшебная палочка и сама по тихому программы устанавливать не умееет!!!
Очень внимательно читаем материалы хотя бы по этим и этой ссылкам!


Полезные сообщения в теме:

Отправлено: 03:34, 10-03-2005

 

Аватара для star_099

Пользователь


Сообщения: 78
Благодарности: 1

Профиль | Отправить PM | Цитировать


Цитата:
Господа!

имеется вопрос:
на скриншоте в первом столбе кол-во программ 40 шт + 4 категории, во втором столбце программ 35 шт + 5 категорий,
что надо сделать чтобы второй столбец был заполнен полностью (там реально место для 2-3 программ)
Может тебе сюда стоит заглянуть, я тут просто смотрел, может это тебе подойдёт

http://forum.oszone.net/showthread.php?p=450899, посмотри пост №228

Отправлено: 17:11, 18-06-2007 | #401



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Аватара для star_099

Пользователь


Сообщения: 78
Благодарности: 1

Профиль | Отправить PM | Цитировать


Изображения
Тип файла: jpg skrin_190607.JPG
(68.6 Kb, 33 просмотров)
Вложения
Тип файла: txt текст cmd-файла.txt
(1.0 Kb, 23 просмотров)

Всем большой привет!
Вот такой вопрос у меня созрел, может кто мне что объяснит.
Вообщем я сделал диск с автоустановкой прог и было всё хорошо, пока не столкнулся с некоторой ситуацией.
Вставляешь диск с прогами, с таймером на автоустановку и всё хорошо, но только притом условии, что в системе стоит один привод.
Если же в системе стоит два привода, то возникаю проблемы. Вставляешь в первый или другой привод диск и загружаешся с диска. Потом, вставляешь на второй привод диск с прогами и начинаешь загрузку, выскакивает вот такое окно (скрин). Если потом нажать на любую кнопку, кроме "повторить", то вся установка проходит хорошо. Эта беда есть и на виртуалке и на физ. приводах. Прога, т.е. WPI почемуто помнит последний привод куда ставили диск с ней. Может сумбурно объяснил, но мне кажется, что не правильно определяется переменная %cdrom%. Версия самой WPI не новая, (я просто не знаю как узнать какая), но не 5.ххх. Как победить проблему?
Вот ещё добавляю текст самого WPI.cmd в котором определяеться пременная диска, с которого стартует прога.
Перечитал не один раз весь этот топик, и признаюсь, кое что понял, но вот эту проблему не могу победить, подскажите как?

Последний раз редактировалось star_099, 22-06-2007 в 20:42. Причина: уточнение вопроса


Отправлено: 16:18, 19-06-2007 | #402


Аватара для star_099

Пользователь


Сообщения: 78
Благодарности: 1

Профиль | Отправить PM | Цитировать


Вложения
Тип файла: txt WPI.txt
(1.1 Kb, 57 просмотров)

Всё я решил свою проблему!!!!
Решение я нашёл на этом топике, не понятное для меня, но оно работает.
Прикрепляю текс cmd-файла, уже нового который решает проблему с определением переменной буквы cdrom

Отправлено: 10:17, 25-06-2007 | #403


Старожил


Сообщения: 253
Благодарности: 22

Профиль | Отправить PM | Цитировать


Подскажите пожалуйста не могу заставить работать*reg файлы как правильно путь писать перепробЫвал разные варииации . Вписываю в секции в реестр до, в реестр после
REGEDIT /S %CDROM%\$OEM$\$1\WPI\Install\SNAGIT.REG
вот так это выглядит в файлике cоnfig.js
Код: Выделить весь код
prog[pn]=['Snagit v8.2.3'];
desc[pn]=['Cнятие скриншотов с экрана монитора,а также захват Видео'];
uid[pn]=['SNAGITV823'];
dflt[pn]=['yes'];
cat[pn]=['Работа с графикой'];
forc[pn]=['no'];
regb[pn]=['REGEDIT /S %CDROM%\\$OEM$\\$1\\WPI\\Install\\SNAGIT.REG'];
cmd1[pn]=['%CDROM%\\$OEM$\\$1\\WPI\\Install\\SNAGIT.EXE  /norestart /qn'];
picf[pn]=['InstallPackage.png'];
picw[pn]=['128'];
pich[pn]=['128'];
textl[pn]=['Right'];
pn++;
Запуск файла проходит нормально
%CDROM%\$OEM$\$1\WPI\Install\SNAGIT.EXE /norestart /qn
и еще вопрос путь к cmd файлу пишется так же как и к обычному файлу или ключи надо какие?

Последний раз редактировалось zver5, 04-07-2007 в 10:48.


Отправлено: 10:40, 04-07-2007 | #404


Аватара для Spirkaa

Старожил


Сообщения: 167
Благодарности: 16

Профиль | Сайт | Отправить PM | Цитировать


zver5, обнови WPI до 6 версии, там исправили баг с двойными ковычками при добавлении файла реестра (сможешь выбрать через проводник свой файл и ничего руками писать не придется)

А строки должны выглядеть примерно так, потому что команды regb[pn] и rega[pn] уже содержнат строку REGEDIT /S

Код: Выделить весь код
regb[pn]=['%wpipath%\\Install\\addons\\regtweaks.reg']; (В реестр до)
rega[pn]=['%wpipath%\\Install\\office\\office2003.reg']; (В реестр после)
Кхм... зачем копировать папку с wpi на винт, если устанавливаешь все равно с CD?
Это сообщение посчитали полезным следующие участники:

Отправлено: 16:20, 04-07-2007 | #405


Старожил


Сообщения: 253
Благодарности: 22

Профиль | Отправить PM | Цитировать


Spirkaa
Копировал на винт так как тренировался Прочитал половину почерпнул массу полезного. Вам спасибо за помощь
А к cmd файлу все так же прописывается пути или есть какие то подводные камни?

Последний раз редактировалось zver5, 04-07-2007 в 20:25.


Отправлено: 19:36, 04-07-2007 | #406


Аватара для star_099

Пользователь


Сообщения: 78
Благодарности: 1

Профиль | Отправить PM | Цитировать


Spirkaa
Может есть у тебя русский хелп к этой версии?

-------
моя аська: 479-пятьсот21-834


Отправлено: 21:11, 04-07-2007 | #407


Аватара для Spirkaa

Старожил


Сообщения: 167
Благодарности: 16

Профиль | Сайт | Отправить PM | Цитировать


zver5, вроде также. Мог бы и с этим потренироваться
star_099, нету. Прочитай для версии 5.* и потом changelog 6 версии и все станет ясно

-------
SVADJ.RU - Диджей с оборудованием на свадьбу в Москве!


Отправлено: 21:51, 04-07-2007 | #408


Старожил


Сообщения: 253
Благодарности: 22

Профиль | Отправить PM | Цитировать


Вложения
Тип файла: txt RUNONCEEX.txt
(278 байт, 49 просмотров)
Тип файла: txt runonceex2.txt
(243 байт, 41 просмотров)

Есть несколько вопросов значит имею 2 вида установки
1. Вариант
WPI с программами копируются на винт устанавливаются и потом папка с этим барахлом удаляется
Как я это реализовывал
На диске
Код: Выделить весь код
|---AUTORUN.EXE
|---AUTORUN.INF
|---BCDWBOOT.BIN
|---BOOTCAT.BIN
|---BOOTCAT.INI
|---BOOTFONT.BIN
|---ICON.ICO
|---NT5BOOT.BIN
|---NT5BOOT1.BIN
|---WIN51
|---WIN51IP
|---WIN51IP.SP2
|---ZVERCD.TXT
|---$OEM$
|   |---CMDLINES.TXT
|   |---runonceex.cmd этот файл запускаю из cmdlines.txt
|   `---$1
|       `---WPI
|        |---WPI.hta
|---I386
|---BCDW
Все работает замечательно, но один минус теряется время на копирование файл на винт
2.Вариант
Все находится на CDROM и устанавливается оттуда
Единственное папка с WPI копируется в корень CD и файл runonceex.cmd немного другой в отличии от первого раза
Все работает замечательно ставится с CD тестил на виртуальной машине
3.Вариант
Хочу отказатся от папки $OEM$ и её содержимого
Понимаю что запуск runonceex.cmd можно(надо) прописать в
WINNT.SIF
[GuiRunOnce]
"%systemdrive%\runonceex.cmd"
но встает вопрос куда ложить runonceex.cmd???
моей фантазии хватило
1.Положил просто тупо файл runonceex.cmd в I386 прописал в
WINNT.SIF
[GuiRunOnce]
"%windir%\runonceex.cmd"
не находит файл
2.Положил файл WPI\runonceex.cmd
WINNT.SIF
[GuiRunOnce]
"%cdrom%\WPI\runonceex.cmd"
не находит файл
3.Вариант
Запускаю из SVCPACK прописываю в inf файл ложу в одноименную папку все работает!!!
Может кто и поскажет как еще можно это сделать желательно из WINNT.SIF ?

Последний раз редактировалось zver5, 06-07-2007 в 10:49. Причина: Дополнения


Отправлено: 00:18, 06-07-2007 | #409


Аватара для Spirkaa

Старожил


Сообщения: 167
Благодарности: 16

Профиль | Сайт | Отправить PM | Цитировать


Народ кто-нибудь решил проблему с установкой перепакованного .NET Framework 2 ?

Отправлено: 11:51, 26-07-2007 | #410



Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 2000/XP/2003 » Вопросы По WPI

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
[решено] создал WPI икону / WPI.ico / для него и файл Autorun.inf tim75 Хочу все знать 7 25-02-2013 06:48
WPI.autorun Pris Автоматическая установка Windows 2000/XP/2003 10 16-01-2012 06:07
Пакет русификации WPI .:[все вопросы]:. Aspirine Автоматическая установка Windows 2000/XP/2003 19 08-08-2010 01:43
wpi-wpi d2201 Автоматическая установка Windows 2000/XP/2003 11 13-04-2005 10:19
PROXY-сервера ---- вопросы, вопросы, вопросы Galosh Хочу все знать 2 09-07-2003 00:57




 
Переход