Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 2000/XP/2003 » Вопросы По WPI

Ответить
Настройки темы
Вопросы По WPI

Аватара для DenchikK

Старожил


Сообщения: 268
Благодарности: 40

Профиль | Отправить PM | Цитировать


Изменения
Автор: Petya V4sechkin
Дата: 10-02-2014




Windows Post Install Wizard (WPI)
Официальный сайт WPI
Официальный форум WPI на MSFN.org

Обзор WPI в статье "Выбор устанавливаемых приложений" (там рассказ о старой версии, но кое-что почерпнуть можно)

Для тех кто в танке: WPI не волшебная палочка и сама по тихому программы устанавливать не умееет!!!
Очень внимательно читаем материалы хотя бы по этим и этой ссылкам!


Полезные сообщения в теме:

Отправлено: 03:34, 10-03-2005

 

Новый участник


Сообщения: 47
Благодарности: 5

Профиль | Отправить PM | Цитировать


Все реги обрабатываются шикарно
А связь я вижу в то что не правильно заданы пути

Отправлено: 03:21, 11-05-2007 | #381



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Аватара для Black Babay

Старожил


Автор проектов


Сообщения: 494
Благодарности: 73

Профиль | Отправить PM | Цитировать


serotka
А почему тогда обрабатываются exe и msi, кстати CMD тоже обрабатываются нормально и если из CMD запустить REG-файл, тоже всё в порядке. Просто бесовщина какая-то...

Отправлено: 11:06, 11-05-2007 | #382


Аватара для Spirkaa

Старожил


Сообщения: 167
Благодарности: 16

Профиль | Сайт | Отправить PM | Цитировать


Black Babay, убери ковычки, которые WPI добавляет. Должно быть что-то вроде этого
Код: Выделить весь код
regb[pn]=['%CDROM%\\SOFT\\addons\\regtweaks.reg'];
А у тебя скорее всего после ' стоит еще и "
Это сообщение посчитали полезным следующие участники:

Отправлено: 09:25, 12-05-2007 | #383


Аватара для Black Babay

Старожил


Автор проектов


Сообщения: 494
Благодарности: 73

Профиль | Отправить PM | Цитировать


Spirkaa
именно так и стоит...

rega[pn]=['"%CDROM%\\WPI\\Install\\DiskTools\\PerfectDisk_Pro_8.0.63\\AutoUpdSettings.reg"'];

Отправлено: 20:58, 12-05-2007 | #384


Аватара для Black Babay

Старожил


Автор проектов


Сообщения: 494
Благодарности: 73

Профиль | Отправить PM | Цитировать


Spirkaa
Спасибо! Все заработало!

Отправлено: 14:02, 13-05-2007 | #385


Старожил


Сообщения: 260
Благодарности: 10

Профиль | Отправить PM | Цитировать


Версия WPI 5.6. Запускаю (с харда), выбираю установить одну программу (для остальных еще не прописал команды), все ставится нормально, а в конце вылетает сообщение об ошибке и с предложением об отладке. Смотрел лог работы - там все нормально. В чем может быть проблема?

Отправлено: 18:38, 15-05-2007 | #386


Аватара для Spirkaa

Старожил


Сообщения: 167
Благодарности: 16

Профиль | Сайт | Отправить PM | Цитировать


Angel_19 у меня такая же трабла, неважно сколько программ устанавливать - в конце вылетает ошибка. На работоспособность не влияет, а неприятненько как-то

Отправлено: 19:57, 15-05-2007 | #387


Аватара для Black Babay

Старожил


Автор проектов


Сообщения: 494
Благодарности: 73

Профиль | Отправить PM | Цитировать


Цитата:
вылетает сообщение об ошибке и с предложением об отладке
У меня такая ботва только если среди устанавливаемых программ есть DotNet. Без него - всё в порядке.

Отправлено: 20:16, 15-05-2007 | #388


Аватара для Spirkaa

Старожил


Сообщения: 167
Благодарности: 16

Профиль | Сайт | Отправить PM | Цитировать


Цитата:
У меня такая ботва только если среди устанавливаемых программ есть DotNet. Без него - всё в порядке
Сегодня, когда на виртуалку ставил, тоже заметил, как заканчивается его установка, вылетает ошибка. А после нее исчезает плеер, кнопки перестают работать (да и надписей на них нет), но установка продолжается.

А еще у меня после установки вылетает сообщение, что-то про файл reboot.js. А потом...появляется ошибка файла sleep.exe, но компьютер все равно перезагружается.

-------
SVADJ.RU - Диджей с оборудованием на свадьбу в Москве!


Отправлено: 07:49, 16-05-2007 | #389


Новый участник


Сообщения: 15
Благодарности: 0

Профиль | Отправить PM | Цитировать


Странно пытаюсь выполнить installreg.cmd из wpi 5.6, config.js выглядит так

prog[pn]=['FAR 1.70-regDiskE'];
uid[pn]=['FAR170REGONLY'];
dflt[pn]=['yes'];
cat[pn]=['Applications'];
forc[pn]=['no'];
excl[pn]=['FAR170FULL'];
cmd1[pn]=['"%CDROM%\\WPI\\Install\\Far\\installreg.cmd"'];
pn++;

c вот таким содержанием

start /wait regedit /s foredisk.reg
exit

foredisk.reg лежит с installreg.cmd в одной папке , при запуске все вроде исполняется
только вот данные в реестр не заносятся. Может надо в бубен постучть если cmd кто
сталкивался с граблями отпишитесь.
Да можно было бы сделать sfx и там все сделать вот ток не хочется мудрить.

И кстати прочему wpi не позволяет просто добавить рег файл без
команд на исполнении в полях command1,command2,итд. Фича или баг?

Отправлено: 20:41, 20-05-2007 | #390



Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 2000/XP/2003 » Вопросы По WPI

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
[решено] создал WPI икону / WPI.ico / для него и файл Autorun.inf tim75 Хочу все знать 7 25-02-2013 06:48
WPI.autorun Pris Автоматическая установка Windows 2000/XP/2003 10 16-01-2012 06:07
Пакет русификации WPI .:[все вопросы]:. Aspirine Автоматическая установка Windows 2000/XP/2003 19 08-08-2010 01:43
wpi-wpi d2201 Автоматическая установка Windows 2000/XP/2003 11 13-04-2005 10:19
PROXY-сервера ---- вопросы, вопросы, вопросы Galosh Хочу все знать 2 09-07-2003 00:57




 
Переход