Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 2000/XP/2003 » Вопросы По WPI

Ответить
Настройки темы
Вопросы По WPI

Аватара для DenchikK

Старожил


Сообщения: 268
Благодарности: 40

Профиль | Отправить PM | Цитировать


Изменения
Автор: Petya V4sechkin
Дата: 10-02-2014




Windows Post Install Wizard (WPI)
Официальный сайт WPI
Официальный форум WPI на MSFN.org

Обзор WPI в статье "Выбор устанавливаемых приложений" (там рассказ о старой версии, но кое-что почерпнуть можно)

Для тех кто в танке: WPI не волшебная палочка и сама по тихому программы устанавливать не умееет!!!
Очень внимательно читаем материалы хотя бы по этим и этой ссылкам!


Полезные сообщения в теме:

Отправлено: 03:34, 10-03-2005

 

Аватара для Sanja Alone

Ищу Человека…


Сообщения: 420
Благодарности: 67

Профиль | Сайт | Отправить PM | Цитировать


Вложения
Тип файла: zip WPIScripts_mod_v54.zip
(4.3 Kb, 47 просмотров)

Вышла новая версия WPI - 5.4 (12 сентября 2006) Список изменений.

Изменений и нововведений хватает. Я отмечу н-рые моменты:
  • Определение cdrom-а из исключенного файла generate.js перекочевало в core.js (см. ф-цию defaultWPI() ).
  • Теперь обязательно нужно назначать уникальные идентификаторы приложениям в config.js. Если параметр uid для какого-то приложения не задан, то отметить его (или снять отметку) можно только непосредственно нажав на флажок (при нажатии на текст, изменения состояния флажка не происходит). Обратите на это внимание!
  • Руководство по программе все-таки пишут...
Модифицированные скрипты для WPI 5.4 с отключенным функционалом отметки чекбоксов категорий вкладываю в этот пост.

-------
Sanja Alone's site (ConvRegToAU3, OEsr, RSA, AutoIt скрипты)


Отправлено: 10:06, 20-09-2006 | #271



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Аватара для gora

Ушёл из жизни


Contributor


Сообщения: 6042
Благодарности: 3487

Профиль | Отправить PM | Цитировать


Дополненный (авторы "потеряли" пару строк в русском файле в сравнении с английским) и исправленный (введены изменения ранее переведенных строк в связи с изменением интерфейса программы), а так же допереведенный русский языковый файл для WPI 5.4 выложил здесь. Буду рад, если для кого то он окажется полезным.

Отправлено: 19:20, 23-09-2006 | #272


Аватара для Sanja Alone

Ищу Человека…


Сообщения: 420
Благодарности: 67

Профиль | Сайт | Отправить PM | Цитировать


gora
Подправил перевод и выложил файл на форуме MSFN в ветке WPI Translations thread.

-------
Sanja Alone's site (ConvRegToAU3, OEsr, RSA, AutoIt скрипты)


Отправлено: 05:05, 24-09-2006 | #273


Аватара для DmitryOlenin

Ветеран


Сообщения: 511
Благодарности: 11

Профиль | Отправить PM | Цитировать


Уже замучился...
На 640x480 просто пустое окно показывается.
Пробовал ставить старые темы, ничего в них не меняя, все то же самое.
Не знаю, что придумать. Подскажите пожалуйста.
В начале установки разрешение именно такое стоит, а видет синий экран с таймером, кнопочками, но без выбора программ как-то неприятно.
Кстати, в 5.4 кажется не работает параметр ShowExtraButtons=false;.
По крайней мере прога на него не реагирует совсем...

Отправлено: 00:16, 30-09-2006 | #274


Аватара для Sanja Alone

Ищу Человека…


Сообщения: 420
Благодарности: 67

Профиль | Сайт | Отправить PM | Цитировать


DmitryOlenin
Цитата:
На 640x480 просто пустое окно показывается
Посмотри первую часть моего ответа DenchikK-у (там, где говорится о кол-ве строк). Еще можешь попробовать установить NumCols=2 (или даже NumCols=1) в WPI\WPIScripts\useroptions.js

Цитата:
Кстати, в 5.4 кажется не работает параметр ShowExtraButtons=false;
Они так специально сделали - если запускаешь с CD/DVD лишних батонов нет, если с HDD - есть. Если тебя это не устраивает, то придется снова покопаться в исходниках.

-------
Sanja Alone's site (ConvRegToAU3, OEsr, RSA, AutoIt скрипты)


Отправлено: 03:18, 30-09-2006 | #275


Ветеран


Сообщения: 628
Благодарности: 51

Профиль | Отправить PM | Цитировать


DmitryOlenin
только что попробовал стандартную тему glossy, в разрешении 640x480 пустого экрана нет, не на реальной не на VMware, ты ничего не менял в скриптах?

Можно еще попробовать отредактирвоать сам файл темы wpi.htm вначале добавить
Код: Выделить весь код
switch (winheight)
{
   case '480':
      maxentries=10;
      break;
Возможно еще придется добавить в api.js
switch (fW)
Код: Выделить весь код
{
   case 640:
      fH=480;
      break;
У меня на 640х480 (1 колонка без пропусков) и в 800х600 (2 колонки) все работает как надо, на версии 5.3 приходилось изголяться с maxentries=
если есть желание могу скинуть свою тему, там хоть в 640х480 нормальная видимость управляемых кнопок и таймера

Отправлено: 07:40, 30-09-2006 | #276


Аватара для DmitryOlenin

Ветеран


Сообщения: 511
Благодарности: 11

Профиль | Отправить PM | Цитировать


EgOrus
Да я даже добивался без редактирования нормального вида.
Только полосу прокрутки было не видно. Вообще... Причем, показывать ее всегда стояло как тру.
Sanja Alone
С махэнртис тоже разбирался, не помогает

Сейчас на виртуалке пошагово сделаю.
1. Прописал в WPI\WPIScripts\globals.js var maxentries=10;, потом 20, потом 2. Не влияет.
2. Прописал в WPI\WPIScripts\useroptions.js NumCols=2, потом 1, потом 4. Не помогает.
3. Добаление в файл wpi.htm и api.js информации о 640x480 тоже результатов не дает.

Это я проверял на отредактированной мною теме Glossy. Я там сделал таймер повыше, убрыл верхнюю полосу с названием, а нижнюю сделал поуже.

Попробовал исходный(оригинальный) wpi.htm.
Кроме того, что также ничего нет, еще и часы "выглядывают" из-под нижней полосы широченной и экран как будто обрезан по краям(вот скорее всего из-за этого "обрезания" полосы прокрутки и не было видно).
Убрал useroptions.js совсем. Ничего не поменялось, только кнопки появились, так как больше не было записи ShowExtraButtons=false;

Вернул полностью(!) оригинальную тему, и директорию WPIScripts, а также, на всякий случай, файл wpi.hta.
То же самое - все есть, кроме программ и возможности их выбрать.

Установка в useroptions.js параметров
Resolution=800; и MonitorResolution=800; меняет разрешение, часы больше не выглядывают стыдливо из-за нижней полосы, но программ как не было, так и нет.

Проверил на реальном компе(не на виртуалке) - все работает. Правда на 640x480 проверить не удалось, так как видюха в этот режим переключаться не хочет.
Казалось бы, можно плюнуть, но... При установке системы на реальный комп получается то же самое, что на виртуалке - WPI запускается, а выбора программ нет

Отправлено: 10:05, 30-09-2006 | #277


Ветеран


Сообщения: 628
Благодарности: 51

Профиль | Отправить PM | Цитировать


DmitryOlenin
Цитата:
Правда на 640x480 проверить не удалось, так как видюха в этот режим переключаться не хочет
Свойства экрана-Параметры-Дополнительно-Адаптер-Список всех режимов-Выбираешь 640х480
а в зависимости от дров ты непроверял, хотя это уже из области маловероятного? (установлены/неустановлены)


Отправлено: 10:44, 30-09-2006 | #278


Аватара для DmitryOlenin

Ветеран


Сообщения: 511
Благодарности: 11

Профиль | Отправить PM | Цитировать


EgOrus
Ты наверное издеваешься надо мной
Я знаю как менять режимы видеокарты, чай второй десяток лет за компом. Нет у меня там 640x480.
И при помощи ресченжера не меняет(говорит, что режим не поддерживается).

Сейчас еще раз проверил. При установке из VmWare все работает. После установки, при запуске скрипта wpi.hta в том же VmWare - пустота.
На реальном компе - все нормально.

Такое уже было у меня... После попытки установить систему на комп получил все то же пустое окно без программ.
Тогда решил при помощи выбора пункта снять выделенное, а потом выбрать все. Вроде появились галочки и программы.
Но это, конечно, не выход.

На виртуалке сейчас этот фокус не проходит.

Отправлено: 11:42, 30-09-2006 | #279


Ветеран


Сообщения: 628
Благодарности: 51

Профиль | Отправить PM | Цитировать


DmitryOlenin
Цитата:
Ты наверное издеваешься надо мной
даже в мыслях не было
я что-то не понимаю...
Цитата:
При установке из VmWare все работает
т.е. WPI запускается при первом логоне в систему, и в этом случае все нормально?
Цитата:
После установки, при запуске скрипта wpi.hta в том же VmWare - пустота
т.е. отработала WPI, закрылось её коно, идешь и запускаешь вручную wpi.hta и тогда проявляется глюк?
хочется проэмулировать у себя такую ситуацию

Отправлено: 11:58, 30-09-2006 | #280



Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 2000/XP/2003 » Вопросы По WPI

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
[решено] создал WPI икону / WPI.ico / для него и файл Autorun.inf tim75 Хочу все знать 7 25-02-2013 06:48
WPI.autorun Pris Автоматическая установка Windows 2000/XP/2003 10 16-01-2012 06:07
Пакет русификации WPI .:[все вопросы]:. Aspirine Автоматическая установка Windows 2000/XP/2003 19 08-08-2010 01:43
wpi-wpi d2201 Автоматическая установка Windows 2000/XP/2003 11 13-04-2005 10:19
PROXY-сервера ---- вопросы, вопросы, вопросы Galosh Хочу все знать 2 09-07-2003 00:57




 
Переход