Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Сфера Microsoft » Microsoft Office (Word, Excel, Outlook и т.д.) » 2019 - Сложение чисел в ячейке, сумму приводим в диапазон 1-22.

Ответить
Настройки темы
2019 - Сложение чисел в ячейке, сумму приводим в диапазон 1-22.

Старожил


Сообщения: 373
Благодарности: 10

Профиль | Отправить PM | Цитировать


Изменения
Автор: okshef
Дата: 21-06-2020
Есть формула.
=СУММ((ДЛСТР(C2)-ДЛСТР(ПОДСТАВИТЬ(C2;{1;2;3;4;5;6;7;8;9};)))*{1;2;3;4;5;6;7;8;9}) она складывает числа в ячейке
есть вторая формула которая сводит числа в диапазон от 1-22
ОСТАТ(А1-1;22)+1
Просьба объединить обе формулы в одну.

Отправлено: 00:02, 21-06-2020

 

Ветеран


Contributor


Сообщения: 26099
Благодарности: 7593

Профиль | Отправить PM | Цитировать


kill-kit, что делают формулы? Что Вы, собственно, хотите получить?

Цитата kill-kit:
она складывает числа в ячейке »
Может быть — цифры числа?
Это сообщение посчитали полезным следующие участники:

Отправлено: 01:43, 21-06-2020 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Старожил


Сообщения: 373
Благодарности: 10

Профиль | Отправить PM | Цитировать


Формула складывает числа и вычитает чтоб сумма уместилась в диапазон от 1-22, 0 меняем на 22 автоматом.
Пример, в ячейке число 9999 нам надо сложить 9+9+9+9 = 36 и затем 36 привести в диапазон от 1-22 , тоесть из 36 мы вычитаем 22 и получаем 14.

Отправлено: 08:23, 21-06-2020 | #3


Ветеран


Contributor


Сообщения: 26099
Благодарности: 7593

Профиль | Отправить PM | Цитировать


kill-kit, тогда так:
Код: Выделить весь код
=ОСТАТ(СУММ(ЗНАЧЕН(ПСТР(C2;СТРОКА(A1:СМЕЩ(A1;ДЛСТР(C2)-1;0));1)));22)
Вводится как формула массива (Ctrl-Shift-Enter).

Или Ваш вариант — аналогично:
Код: Выделить весь код
=ОСТАТ(СУММ((ДЛСТР(C2)-ДЛСТР(ПОДСТАВИТЬ(C2;{1;2;3;4;5;6;7;8;9};)))*{1;2;3;4;5;6;7;8;9});22)
Это сообщение посчитали полезным следующие участники:

Отправлено: 09:03, 21-06-2020 | #4


Старожил


Сообщения: 373
Благодарности: 10

Профиль | Отправить PM | Цитировать


Спасибо!

Отправлено: 10:53, 21-06-2020 | #5


Ветеран


Contributor


Сообщения: 2049
Благодарности: 1245

Профиль | Отправить PM | Цитировать


Iska, В Ваших формулах при сумме чисел =22 результат =0, а надо 22. Без если не прокатит?
Код: Выделить весь код
=ЕСЛИ(ОСТАТ(СУММПРОИЗВ(--ПСТР(C4;СТРОКА(ДВССЫЛ("A1:A"&ДЛСТР(ЦЕЛОЕ(C4))));1));22)<>0;ОСТАТ(СУММПРОИЗВ(--ПСТР(C4;СТРОКА(ДВССЫЛ("A1:A"&ДЛСТР(ЦЕЛОЕ(C4))));1));22);22)
Взял отсюда сложение цифр числа

-------
Даже самая сложная проблема обязательно имеет простое, лёгкое для понимания, неправильное решение. Каждое решение плодит новые проблемы.

Это сообщение посчитали полезным следующие участники:

Отправлено: 13:42, 21-06-2020 | #6


Ветеран


Contributor


Сообщения: 26099
Благодарности: 7593

Профиль | Отправить PM | Цитировать


Цитата megaloman:
Iska, В Ваших формулах при сумме чисел =22 результат =0, а надо 22. »
Я пропустил:
Цитата kill-kit:
0 меняем на 22 автоматом. »

Отправлено: 17:20, 21-06-2020 | #7



Компьютерный форум OSzone.net » Сфера Microsoft » Microsoft Office (Word, Excel, Outlook и т.д.) » 2019 - Сложение чисел в ячейке, сумму приводим в диапазон 1-22.

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Delphi - Паскаль, сложение двух чисел побитово lixod96 Программирование и базы данных 0 26-04-2014 15:39
Assm - Сложение двух чисел Rebel666 Программирование и базы данных 8 22-04-2012 17:30
CMD/BAT - Сложение чисел в переменной Доктор Ливси Скриптовые языки администрирования Windows 2 12-01-2012 13:15
C/C++ - Как правильно задать диапазон генерации случайных чисел perfomanse Программирование и базы данных 6 03-07-2010 22:10
Сложение строк на PHP Vlad Drakula Вебмастеру 1 08-06-2003 21:30




 
Переход