Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 10 / 8 / 7 / Vista » 7 / 2008 R2 - [решено] SETUPCOMPLETE.CMD не работает "Start"?

Ответить
Настройки темы
7 / 2008 R2 - [решено] SETUPCOMPLETE.CMD не работает "Start"?

Новый участник


Сообщения: 8
Благодарности: 0

Профиль | Отправить PM | Цитировать


Изменения
Автор: kravenrus
Дата: 06-02-2018
SETUPCOMPLETE.CMD:
Код: Выделить весь код
mkdir "%SYSTEMDRIVE%\Users\Default\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts"
mkdir "%SYSTEMDRIVE%\Users\Default\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar"
copy "%WINDIR%\Setup\Copy\ImplicitAppShortcuts" "%SYSTEMDRIVE%\Users\Default\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts"
copy "%WINDIR%\Setup\Copy\TaskBar" "%SYSTEMDRIVE%\Users\Default\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar"
reg import %WINDIR%\Setup\RegTweaks\HKEY_CLASSES_ROOT_Custom.reg
reg load HKEY_USERS\Custom %SYSTEMDRIVE%\Users\Default\NTUSER.DAT
reg import %WINDIR%\Setup\RegTweaks\HKEY_CURRENT_USER_Custom.reg
reg unload HKEY_USERS\Custom
start /wait addUser.exe
start /wait 7z1801.exe
EXIT
addUser.exe - 7SFX архив, внутри которого .bat с таким содержимым:
Код: Выделить весь код
@echo off
TITLE addUser by krav_en
color 17
mode con cols=90 lines=29
GOTO BEGIN

:BEGIN

cls
echo.
echo. ======================================================================================
echo.                                   Добро пожаловать!
echo.               "Программа" разработана для личного пользования. by krav_en
echo.  Для продолжения работы с программой введите число, соответствующее группе, к которой
echo.                      будет принадлежать новая учетная запись.
echo.             Это действие можно пропустить нажав на соответствующую клавишу!
echo. ======================================================================================
echo.
echo.                                    1. Пользователи
echo.                                   2. Администраторы
echo.                                  0. Покинуть программу
echo.
echo. ======================================================================================
echo.
set /P localgroup=
IF %localgroup% EQU 0 GOTO FINISH
IF %localgroup% EQU 1 GOTO NEWUSER
IF %localgroup% EQU 2 GOTO NEWADMIN

:NEWUSER
set /P newusername="Имя учетной записи (макс. 20 символов): "
set /P newuserpass="Пароль учетной записи (макс. 14 символов) [НЕОБЯЗЯТЕЛЬНО]: "

net user %newusername% %newuserpass% /add
net accounts /maxpwage:unlimited

PAUSE
GOTO BEGIN

:NEWADMIN
set /P newusername="Имя учетной записи (макс. 20 символов): "
set /P newuserpass="Пароль учетной записи (макс. 14 символов) [ОБЯЗЯТЕЛЬНО]: "

net user %newusername% %newuserpass% /add
net localgroup Administrators %newusername% /add
net localgroup Users %newusername% /delete
net localgroup Администраторы %newusername% /add
net localgroup Пользователи %newusername% /delete
net accounts /maxpwage:unlimited

PAUSE
GOTO BEGIN

:FINISH

PAUSE
EXIT
На этапе последней настройки Windows выполняется все будто строк start и нет вовсе, далее переход к Рабочему столу системы (но перед этим еще ошибка, говорящая мол не удалось запустить службу пользователей, или что-то в этом роде - перезапуск системы решает её). Смена последовательности команд start (сначала запуск установщика 7ZIP) - результат тот же.

Все выполняется без проблем, кроме запуска .exe, такого рода тоже не работало - call cod.cmd. Будь addUser.exe и 7z1801.exe в одной директории вместе с SETUPCOMPLETE.CMD или в %WINDIR%\System32\ - результата нет.

Пробовал так, файлы соответственно находятся по указанному пути - без результатов:
start /wait %WINDIR%\Setup\Install\addUser.exe
start /wait %WINDIR%\Setup\Install\7z1801.exe

На этапе создания администратора задаю ему пароль, может ли это являться причиной проблем? Хотя ведь манипуляции с реестром проходят О_о
Самое интересное что иногда .exe запускался, код был тот же. Им же тогда был этот addUser. А когда не запускался, то выдавал ошибку
Цитата:
мол не удалось запустить службу пользователей, или что-то в этом роде
SETUPCOMPLETE.CMD добавлялся в режиме аудита (многократно редактировался в смонтированной из .wim папке).
Всю голову уже сломал, может я что-то не учел, максимальное количество строк в SETUPCOMPLETE.CMD, к примеру О_о
А может есть какой способ сделать SETUPCOMPLETE.CMD видимым? Чтобы хоть как-то проконтролировать, что происходит? Пытался запускать скрипт так:
Код: Выделить весь код
run.cmd>>C:\log.txt
Содержимое SETUPCOMPLETE.CMD тогда было перенесено в run.cmd. В итоге run.cmd запустился, все прошло успешно (манипуляции с копированием и реестром), установки (addUser) 7ZIP не начиналось. В логе, не увидел ни одной строчки с командой start (может сделал чего не правильно). Лог окончился командой:
Код: Выделить весь код
...
...
...
reg unload HKEY_USERS\Custom

(было ли сообщение о успешном выполнении - не помню)

Отправлено: 00:28, 06-02-2018

 

Новый участник


Сообщения: 8
Благодарности: 0

Профиль | Отправить PM | Цитировать


Вроде получилось решить.
Данная часть скрипта с изменениями (решил что из-за неё пролетали следующие строки в SETUPCOMPLETE.CMD, поскольку на этапе применения твиков реестра и выгрузки куста - выдавало ошибку, но почему-то не смотря на это все работало как надо) была перенесена в отдельный .cmd файл:
Код: Выделить весь код
mkdir "%SYSTEMDRIVE%\Users\Default\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts"
mkdir "%SYSTEMDRIVE%\Users\Default\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar"

copy "%~dp0Copy\ImplicitAppShortcuts" "%SYSTEMDRIVE%\Users\Default\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts"
copy "%~dp0Copy\TaskBar" "%SYSTEMDRIVE%\Users\Default\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar"

reg load HKEY_USERS\Custom "%SYSTEMDRIVE%\Users\Default\NTUSER.DAT"
reg import "%~dp0RegTweaks\HKEY_CURRENT_USER_Custom.reg"
reg unload HKEY_USERS\Custom
reg import "%~dp0RegTweaks\HKEY_CLASSES_ROOT_Custom.reg"
Далее скрипт вместе с сопутствующими папками и файлами был сжат в SFX архив "new.exe".

Сами же строки в SETUPCOMPLETE.CMD теперь имеют формат:
Код: Выделить весь код
start /wait addUser.exe
start /wait new.exe
EXIT
Два раза протестировал - вроде работает и ничего не пропускает.

Отправлено: 18:08, 09-02-2018 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.



Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 10 / 8 / 7 / Vista » 7 / 2008 R2 - [решено] SETUPCOMPLETE.CMD не работает "Start"?

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Службы - [решено] ошибка "прекращенна работа программы "start" rezus2008@vk Microsoft Windows 7 7 08-08-2014 11:15
7 / 2008 R2 - [решено] Не работает SetupComplete.cmd Qweezy Автоматическая установка Windows 10 / 8 / 7 / Vista 5 09-07-2014 23:32
[решено] Как удалить содержимое папок "Моя Музыка" и "Мои Рисунки" через CMD Ivan_009 Автоматическая установка Windows 2000/XP/2003 10 14-01-2013 20:45
Почему Windows при запуске файла с именем "start.exe" показывает кнопки как "Пуск"? Котяра Хочу все знать 9 22-06-2009 13:48
Запретить/удалить пункт "Programs" ("Программы") из меню кнопки "Start" ("Пуск") submaster Microsoft Windows NT/2000/2003 5 13-09-2006 12:29




 
Переход