Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Linux и FreeBSD » Программное обеспечение Linux и FreeBSD » вопрос про установке софта в Linux

Ответить
Настройки темы
вопрос про установке софта в Linux

Пользователь


Сообщения: 65
Благодарности: 1

Профиль | Отправить PM | Цитировать


Вопрос такого характера, я по мануалу, ставлю из исходников например asterisk или другой софт для Linux, и мне нужно с ним поставить libpri — библиотеку, в мануал написано, что нужна установка версии 1.4.* а на сайте уже есть 1.6.*, с точки зрения глюков, нужно ли мне искать версию 1.4.*, или же не загоняться и ставить 1.6.*?

Отправлено: 21:34, 10-10-2017

 

Аватара для Charg

Ветеран


Сообщения: 2059
Благодарности: 285

Профиль | Отправить PM | Цитировать


Alex_Foks, нужно ставить ту, которую рекомендовал мейнтейнер пакета, т.е. 1.4.*. Оно то на первый взгляд может и с 1.6 заработает, но когда-нибудь через 2 месяца, когда ты уже забудешь про эти библиотеки - внезапно окажется что какая-то функция в этой библиотеке отсутствует или реализована по другому и процесс будет падать а ты будешь биться с вопросом почему.

Отправлено: 09:18, 11-10-2017 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Аватара для Rezor666

Ветеран


Сообщения: 2735
Благодарности: 336

Профиль | Сайт | Отправить PM | Цитировать


Цитата Alex_Foks:
ставлю из исходников например »
Всегда старайтесь искать пакет, а не ставить из исходников.
И в любом случае лучше всегда использовать свежие пакеты и регулярно ставить обновления.

-------
"Средства у нас есть. У нас ума не хватает..."


Отправлено: 10:22, 11-10-2017 | #3


ИО Капитана Очевидности


Contributor


Сообщения: 5122
Благодарности: 1051

Профиль | Отправить PM | Цитировать


Цитата Alex_Foks:
в мануал написано, что нужна установка версии 1.4.* а на сайте уже есть 1.6.* »
Вот прям так именно 1.4? Может быть не ниже 1.4?
./configure обычно проверяет все требуемые пакеты по условию "не ниже"

Ставьте актуальную версию из репозитория.

Цитата Charg:
какая-то функция в этой библиотеке отсутствует или реализована по другому »
Вам известны случаи такой "обратной несовместимости"?
Даже если какая-то функция будет "реализована по другому" (повышена скорость работы и т.д.), то её результат всё равно будет точно таким-же.

-------
Самое совершенное оружие, которым забиты арсеналы богатых и процветающих наций, может легко уничтожить необразованного, больного, бедного и голодного. Но оно не может уничтожить невежество, болезнь, нищету и голод. (Фидель Кастро)

Почему всех осужденных за измену Родине при Сталине реабилитировали при Горбачёве по отсутствию состава преступления? Потому что при Горбачёве измену Родине перестали считать преступлением.

Это сообщение посчитали полезным следующие участники:

Отправлено: 02:30, 16-10-2017 | #4


Аватара для Charg

Ветеран


Сообщения: 2059
Благодарности: 285

Профиль | Отправить PM | Цитировать


El Scorpio, лично мне - нет, не известны, но вероятность такого события явно не нулевая.

Отправлено: 10:34, 16-10-2017 | #5


Аватара для yurfed

Просто волшебник


Сообщения: 17245
Благодарности: 2686

Профиль | Отправить PM | Цитировать


Alex_Foks, самый дурацкий вопрос - вы к интернету подключены. Тянет оттуда, либо с дистрибутива.
Цитата Alex_Foks:
например asterisk »
А вы уверены что все эти пакеты имеются в этой сборке?
Качайте молодой человек.

Отправлено: 14:09, 16-10-2017 | #6


Странный тип


Сообщения: 782
Благодарности: 67

Профиль | Отправить PM | Цитировать


Цитата El Scorpio:
Вам известны случаи такой "обратной несовместимости"? »
Множество.
Первое, что на ум приходит: poppler.
Там постоянно что-то ломают в новых версиях.

-------
Сколько не думай, а лучше водки ничего не придумаешь.


Отправлено: 22:36, 21-10-2017 | #7



Компьютерный форум OSzone.net » Linux и FreeBSD » Программное обеспечение Linux и FreeBSD » вопрос про установке софта в Linux

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Доступ - Ошибка 0x80070005 - Отказано в доступе. При установке софта zahar_92 Microsoft Windows 7 17 09-06-2016 14:53
Прочее - Вопрос чайника про linux- установка, скайп, интернет и вирусы illusionmgs Общий по Linux 13 19-03-2012 22:59
Debian/Ubuntu - Вопрос по установке debian linux klesk Общий по Linux 5 02-03-2012 11:27
Mandriva/Mandrake - Вопрос по установке Linux Mandriva PowerPack 2010 i586 Izeek Общий по Linux 4 31-08-2010 09:03
[решено] карта 1600 про вопрос про S-Video GLOVER Видеокарты 2 01-12-2009 05:48




 
Переход