Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Linux и FreeBSD » Общий по Linux » Debian/Ubuntu - Проблемы с Nouveau Prime

Ответить
Настройки темы
Debian/Ubuntu - Проблемы с Nouveau Prime

Аватара для Fire_Dash42

Новый участник


Сообщения: 28
Благодарности: 1


Конфигурация

Профиль | Отправить PM | Цитировать


Здравствуйте! На днях столкнулся с проблемой с запуском игр на своём ноутбуке.
Поискал инструкцию по использованию карточки от Nvidia как основное устройство рендеринга и вывод картинки через карточку от Intel, используя открытый драйвер и сделал всё по этой инструкции: http://help.ubuntu.ru/wiki/prime.
После того, как выполнил все условия инструкции, попробовал запускать игры через терминал, указывая ключ "DRI_PRIME=1" в начале команды и они шли нормально (если не учитывать подтормаживания из-за перегревания оборудования), но после какого-то обновления драйверов игры таким образом запускаться перестали.
Вот результат вывода после отправления команды (на примере запуска игры Terraria):
Код: Выделить весь код
lemonzest@Acer-Aspire-E1-571G:~$ DRI_PRIME=1 "/home/lemonzest/GOG Games/Terraria/start.sh"
Running Terraria
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  149 ()
  Minor opcode of failed request:  2
  Serial number of failed request:  137
  Current serial number in output stream:  138
lemonzest@Acer-Aspire-E1-571G:~$
Если запускать другие программы с этим ключом (например, Kdenlive), то они идут нормально.
С проблемой уже неделю вожусь, поиски в Google не выдают ничего толкового касательно моей ошибки. Что делать?

-------
Если скажут "Прыгай", то спроси "Как высоко?".


Отправлено: 10:08, 29-07-2017

 
zai zai вне форума

Аватара для zai

Ветеран


Сообщения: 4312
Благодарности: 552

Профиль | Отправить PM | Цитировать


Цитата Fire_Dash42:
Что делать? »
Установить bumblebee

-------
А зачем тебе жужжать, если ты не пчела? По-моему так.


Отправлено: 17:56, 31-07-2017 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Аватара для Fire_Dash42

Новый участник


Сообщения: 28
Благодарности: 1

Профиль | Отправить PM | Цитировать


Цитата zai:
Установить bumblebee »
А с текущим Праймом конфликта не будет? Просто надумываю установить, но боюсь.

-------
Если скажут "Прыгай", то спроси "Как высоко?".


Отправлено: 07:13, 02-08-2017 | #3


Аватара для Fire_Dash42

Новый участник


Сообщения: 28
Благодарности: 1

Профиль | Отправить PM | Цитировать


Цитата Fire_Dash42:
А с текущим Праймом конфликта не будет? »
Раз уж так получилось, отвечу сам себе: да, не будет. Просто надо было немного повозиться с этим Bumblebee, его же конфигом и драйвером Nvidia (система мне предлагает версию 340.102 из nvidia-340). Надо было использовать установленный вместе с набором пакетов bumblebee проприетарный драйвер "nvidia-340", а не "nvidia" и "nvidia-current".
С драйвера nouveau переходить не стал, ноутбук нормально тянет графические навороты системы.

Вот вывод команды в Konsole:
Код: Выделить весь код
lemonzest@Acer-Aspire-E1-571G:~$ optirun "/home/lemonzest/GOG Games/Terraria/start.sh"
Running Terraria
IGLDevice: OpenGLDevice
OpenGL Device: GeForce 710M/PCIe/SSE2
OpenGL Driver: 4.2.0 NVIDIA 304.135
OpenGL Vendor: NVIDIA Corporation
MojoShader Profile: glsl120
EXT_swap_control_tear unsupported. Fall back to standard VSync.
EXT_swap_control_tear unsupported. Fall back to standard VSync.
EXT_swap_control_tear unsupported. Fall back to standard VSync.
EXT_swap_control_tear unsupported. Fall back to standard VSync.
EXT_swap_control_tear unsupported. Fall back to standard VSync.
Разрешение изменено на: 1366x768.
lemonzest@Acer-Aspire-E1-571G:~$
Игра пошла, всё чётко.

-------
Если скажут "Прыгай", то спроси "Как высоко?".


Последний раз редактировалось Fire_Dash42, 02-08-2017 в 09:44.


Отправлено: 09:28, 02-08-2017 | #4

zai zai вне форума

Аватара для zai

Ветеран


Сообщения: 4312
Благодарности: 552

Профиль | Отправить PM | Цитировать


Цитата Fire_Dash42:
optirun "/home/lemonzest/GOG Games/Terraria/start.sh" »
Не знаю как щас, но раньще было приложение primus, которое на много ускоряло работу optirun, если оно до сих пор существует используй его.

-------
А зачем тебе жужжать, если ты не пчела? По-моему так.


Отправлено: 14:29, 03-08-2017 | #5


Аватара для Fire_Dash42

Новый участник


Сообщения: 28
Благодарности: 1

Профиль | Отправить PM | Цитировать


zai, да, primus идёт вместе со всем набором нужных инструментов для Bumblebee, если судить по предлагаемой им команде для Терминала:
Код: Выделить весь код
sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic
И по их же предложению в дополнительных настройках:
Код: Выделить весь код
optirun -b primus <app>
Но у меня теперь появились следующие вопросы:

1. Можно ли и дальше обновлять драйверы из репозитория "oibaf/graphics-drivers" или лучше оставить его выключенным?
2. При использовании ключа "optirun -b primus" (и без "-b primus") для запуска программы Kdenlive, она запускается и работает нормально, но при попытке закрыть её появляется уведомление "Сбой программы <<Kdenlive>>". С играми всё нормально, но вот такое поведение программы я не понимаю. С чем это может быть связано?

-------
Если скажут "Прыгай", то спроси "Как высоко?".


Последний раз редактировалось Fire_Dash42, 03-08-2017 в 18:17.


Отправлено: 18:10, 03-08-2017 | #6

zai zai вне форума

Аватара для zai

Ветеран


Сообщения: 4312
Благодарности: 552

Профиль | Отправить PM | Цитировать


Цитата Fire_Dash42:
Можно ли и дальше обновлять драйверы из репозитория "oibaf/graphics-drivers" или лучше оставить его выключенным? »
Понятия не имею, что это за репозиторий - вот официальный проект.
Вот ссылки:
https://wiki.ubuntu.com/Bumblebee#Installation
http://help.ubuntu.ru/wiki/bumblebee
http://forum.ubuntu.ru/index.php?topic=190100.0
Цитата Fire_Dash42:
При использовании ключа "optirun -b primus" (и без "-b primus") для запуска программы Kdenlive, она запускается и работает нормально, но при попытке закрыть её появляется уведомление "Сбой программы <<Kdenlive>>". С играми всё нормально, но вот такое поведение программы я не понимаю. С чем это может быть связано? »
Никаких сбоев быть не должно при правильной установке, а запускать нужно с ключом b.

-------
А зачем тебе жужжать, если ты не пчела? По-моему так.


Отправлено: 21:42, 03-08-2017 | #7


Аватара для Fire_Dash42

Новый участник


Сообщения: 28
Благодарности: 1

Профиль | Отправить PM | Цитировать


Цитата zai:
Никаких сбоев быть не должно при правильной установке »
Ну, я устанавливал Bumblebee, следуя инструкциям. Наверное, просто недочёт в самом Kdenlive, раз крашится при закрывании, если запущена с использованием карточки от Nvidia.

Зато карточка определяется нормально, что не может не радовать:
Код: Выделить весь код
lemonzest@Acer-Aspire-E1-571G:~$ optirun glxinfo | grep "OpenGL renderer"
OpenGL renderer string: GeForce 710M/PCIe/SSE2
lemonzest@Acer-Aspire-E1-571G:~$
С использованием ключа DRI_PRIME=1 раньше писал:
Код: Выделить весь код
OpenGL renderer string: NVD7
В принципе, можно считать, что проблема решилась переходом на Bumblebee и запуском игр ключом "optirun -b primus" при открытых форточках, чтобы ветерок залетал.

Может, информацию о падении программы надо предоставить, чтобы понять, что случилось?

-------
Если скажут "Прыгай", то спроси "Как высоко?".


Отправлено: 11:41, 05-08-2017 | #8


Аватара для Fire_Dash42

Новый участник


Сообщения: 28
Благодарности: 1

Профиль | Отправить PM | Цитировать


И ещё это настораживает:
Код: Выделить весь код
lemonzest@Acer-Aspire-E1-571G:~$ sudo apt update
Игн:1 http://dl.google.com/linux/chrome/deb stable InRelease
Сущ:2 http://repo.yandex.ru/yandex-browser/deb beta InRelease                             
Сущ:3 http://ru.archive.ubuntu.com/ubuntu zesty InRelease                                 
Сущ:4 http://repo.steampowered.com/steam precise InRelease                                
Пол:5 http://dl.google.com/linux/chrome/deb stable Release [1*189 B]                      
Сущ:6 http://ru.archive.ubuntu.com/ubuntu zesty-updates InRelease                         
Пол:7 http://security.ubuntu.com/ubuntu zesty-security InRelease [89,2 kB]                
Пол:8 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]                    
Сущ:9 http://ru.archive.ubuntu.com/ubuntu zesty-backports InRelease                       
Игн:10 http://ppa.launchpad.net/bumblebee/stable/ubuntu zesty InRelease                   
Сущ:11 https://dl.winehq.org/wine-builds/ubuntu zesty InRelease                           
Сущ:12 http://ppa.launchpad.net/i-nex-development-team/daily/ubuntu zesty InRelease       
Сущ:13 http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu zesty InRelease
Сущ:14 http://ppa.launchpad.net/qbittorrent-team/qbittorrent-stable/ubuntu zesty InRelease
Ошк:15 http://ppa.launchpad.net/bumblebee/stable/ubuntu zesty Release
  404  Not Found
Сущ:16 https://repo.skype.com/deb stable InRelease
Пол:17 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1*367 B]
Чтение списков пакетов… Готово                                    
E: Репозиторий «http://ppa.launchpad.net/bumblebee/stable/ubuntu zesty Release» не содержит файла Release.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, и поэтому по умолчанию он отключён.
N: Смотрите справочную страницу apt-secure(8) о создании репозитория и настройке пользователя.
lemonzest@Acer-Aspire-E1-571G:~$
А если быть точнее, то вот эти куски из выхлопа команды:
Код: Выделить весь код
Ошк:15 http://ppa.launchpad.net/bumblebee/stable/ubuntu zesty Release
  404  Not Found
Код: Выделить весь код
E: Репозиторий «http://ppa.launchpad.net/bumblebee/stable/ubuntu zesty Release» не содержит файла Release.
Это из-за того, что последнее обновление в репозитории было в 2015 году?

-------
Если скажут "Прыгай", то спроси "Как высоко?".


Отправлено: 09:11, 06-08-2017 | #9



Компьютерный форум OSzone.net » Linux и FreeBSD » Общий по Linux » Debian/Ubuntu - Проблемы с Nouveau Prime

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Prestigio MultiPad 2 Prime Duо pmp5780d слетает прошивка. Teshub Мобильные ОС, смартфоны и планшеты 1 07-09-2015 20:50
Suse/OpenSuSE - Как включить nouveau в opensuse 12.3? po9g3dh Общий по Linux 12 22-07-2013 22:02
LifeView FlyTV Prime 30 под Windows 7 x64 spcr Поиск драйверов, прошивок и руководств 3 01-01-2011 20:26
Медиа - ТВ-тюнер FlyTV 34 Prime и Windows 7 LRC Microsoft Windows 7 5 26-04-2010 00:26
2008 - Server 2008 и тюнер Life View Fly TV Prime 3x Series/Fly DV Prime 3x series winter2014 Windows Server 2008/2008 R2 9 24-11-2009 10:13




 
Переход