Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Серверные продукты Microsoft » Windows Server 2008/2008 R2 » 2008 R2 - Не достаточно прав у пользователей

Ответить
Настройки темы
2008 R2 - Не достаточно прав у пользователей

Новый участник


Сообщения: 14
Благодарности: 0

Профиль | Отправить PM | Цитировать


Windows 2008 R2 все работают по RDP.

Ситуация №1.
Если есть админские права на сервере, то при заходе в программу 1С-торговое оборудование, в поле "имя компьютера" отображается имя компьютера с которого зашли на сервер. И это правильно.

Ситуация №2.
Если есть только права пользователя, то при заходе в программу 1С-торговое оборудование, в поле "имя компьютера" отображается имя сервера этого сервера. И это не правильно.

Т.е. у пользователей скорее всего недостаточно прав на какой то каталог на сервере. Понять не могу на какой. На каталог с 1С пользователям дал полные права. Не помогло.

На всякий случай скину код 1с где определяется имя компьютера. Может это поможет решить проблему.

Код: Выделить весь код
// Процедура получения имени компьютера для
// привязки ТО к компьютеру, в т.ч. в терминальной сессии
Функция ПолучитьИмяКомпьютера() Экспорт
	
	ИмяКомпьютера = "";
	Попытка
		Shell = Новый COMОбъект("WScript.Shell");
		ИмяКомпьютера = Shell.ExpandEnvironmentStrings("%CLIENTNAME%");
		Если ИмяКомпьютера = "%CLIENTNAME%" Тогда
			ИмяКомпьютера = "";
		КонецЕсли;
	Исключение
	КонецПопытки;
	
	Если ПустаяСтрока(ИмяКомпьютера) ИЛИ (НРег(СокрЛП(ИмяКомпьютера)) = "console") Тогда
		ИмяКомпьютера = ИмяКомпьютера();
	КонецЕсли;
	
	Возврат ВРег(ИмяКомпьютера);
	
КонецФункции

Отправлено: 17:09, 20-05-2019

 

Новый участник


Сообщения: 14
Благодарности: 0

Профиль | Отправить PM | Цитировать


Дело было в ярлыке. Пересоздал заработало

Отправлено: 18:24, 20-05-2019 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.



Компьютерный форум OSzone.net » Серверные продукты Microsoft » Windows Server 2008/2008 R2 » 2008 R2 - Не достаточно прав у пользователей

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Доступ - Ограничение прав пользователей pandarianin Microsoft Windows 7 13 19-01-2015 13:49
Достаточно ли возможностей Office Web Apps для пользователей планшетных компьютеров? OSZone News Новости и события Microsoft 0 11-09-2010 17:30
Главная учетная запись Администратор не имеет достаточно прав Ara_777 Microsoft Windows NT/2000/2003 7 12-05-2010 12:13
Доступ - Ограничение прав пользователей spaced Microsoft Windows 7 13 27-04-2010 09:37
Ограничение прав пользователей Zion666 Microsoft Windows 2000/XP 5 17-05-2007 15:25




 
Переход