Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 10 / 8 / 7 / Vista » 10 / 2016 - [решено] Проблема при установке с файлом автоответов

Ответить
Настройки темы
10 / 2016 - [решено] Проблема при установке с файлом автоответов

Новый участник


Сообщения: 25
Благодарности: 1

Профиль | Отправить PM | Цитировать


Изменения
Автор: Malukov.Dmitry
Дата: 15-01-2019
Всем дорого утра !

Такая ситуевина: есть - два образа Windows 10 разных разрядностей, с тремя редакциями в каждом.

Была задача : скипнуть EULA, Ввода ключа и ProtectYourPC (в основном последнюю, так как она по моим наблюдениям херила некоторые предварительные настройки, вне зависимости от выбранных на ней параметров), НО - при этом оставит ручной выбор редакции !

Из мануалов я не извлек как реализовать последнее, поэтому просто указал несуществующую редакцию.
И что удивительно, это сработало. И на домашнем ПК и в VirtualBox..... но не на ноуте.
Программа установки сообщала, что редакций не найдено.

Ну, собственно - вопросов больше чем ответов. Почему программа установки обнаружила косяк в файле автоответов только на ноуте и как реализовать выше перечисленное - чтобы всем было хорошо.

Прилагаю файл автоответов от x86-образа. Они в принципе почти идентичны.
Скрытый текст

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>3</ProtectYourPC>
</OOBE>
</component>
</settings>
<settings pass="windowsPE">
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Diagnostics>
<OptIn>false</OptIn>
</Diagnostics>
<DynamicUpdate>
<WillShowUI>OnError</WillShowUI>
</DynamicUpdate>
<ImageInstall>
<OSImage>
<WillShowUI>OnError</WillShowUI>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/NAME</Key>
<Value>Windows 10 Профессиональная (x86)</Value>
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>
<UserData>
<AcceptEula>true</AcceptEula>
<ProductKey>
<Key></Key>
</ProductKey>
</UserData>
</component>
</settings>
</unattend>



Без файла автоответов - естественное все работает. Ну, кроме того, что нужно.

Отправлено: 01:53, 15-01-2019

 

(*.*)


Administrator


Сообщения: 34558
Благодарности: 6053

Профиль | Сайт | Отправить PM | Цитировать


1. На ноутбуке лицензия и издание поднимается из UEFI BIOS.

2. Издание выбирается по ключу в файле ответов, что позволяет переопределить п. 1

3. Официальных образов с тремя изданиями нет. В остальных может быть что угодно, поэтому про них надо спрашивать не здесь, а там где вы их взяли.

Отправлено: 03:08, 15-01-2019 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Новый участник


Сообщения: 25
Благодарности: 1

Профиль | Отправить PM | Цитировать


В общем дело такое - взял я оригинальные образы MSDN, внес необходимые изменения в nLite и ручками, ну и записал на флешку при помощи WinSetupFromUSB. Живут на флешке 4 iso-шника. 2 с семеркой , 2 с десяткой (в каждом три редакции). Скорее всего имеет место первый вариант появления проблемы - описанный вами . Тогда встает другой вопрос : как скипнуть диалоги без файла автоответов ? Настройку конфиденциальности можно скипнуть добавлением политики в реестр в install.wim.
Скрытый текст
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\OOBE]
"DisablePrivacyExperience"=dword:00000001

Правда она описана как применимая к новым учетным записям. Не факт, что сработает при создании ПЕРВОЙ учетки после установки.
Попробую провернуть. Что можно сделать с диалогом EULA\Ввода ключа, при этом имея возможность выбрать редакцию вручную ?

Отправлено: 04:35, 15-01-2019 | #3


Новый участник


Сообщения: 25
Благодарности: 1

Профиль | Отправить PM | Цитировать


Проблема решилась, но весьма интересно. В оригинальном образе присутствовал файлик EI.CFG, который был выпилен программой WinAIO. Создал пустой файл, и указал в нем заведомо неиспользуемую производителями оборудования конфигурацию. В файле автоответов указал заведомо несуществующий индекс (0). Теперь программа установки игнорирует инфу из UEFI, и так-как указанная редакция отсутствует - отображает диалог выбора редакции. Естественно, обязателен параметр <WillShowUI>OnError</WillShowUI>.

Отправлено: 06:10, 15-01-2019 | #4



Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 10 / 8 / 7 / Vista » 10 / 2016 - [решено] Проблема при установке с файлом автоответов

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Установка - Проблема при установке windows xр-выдает ошибку на установке driver.cap Respektabel Microsoft Windows 2000/XP 2 28-06-2010 10:09
проблема при установке 2-го IDE винта, при имеющемся SATA винтe dolphin_xxx Непонятные проблемы с Железом 4 23-12-2009 22:17
Установка - Проблема при установке roots Microsoft Windows 2000/XP 3 14-04-2008 15:59
Установка - проблема при установке Vladik23 Microsoft Windows 2000/XP 2 26-03-2008 17:56
Проблема при установке Rustem Microsoft Windows 95/98/Me 7 27-10-2007 00:35




 
Переход