Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Linux и FreeBSD » Общий по Linux » Глюки с переключением раскладки в KDE

Ответить
Настройки темы
Глюки с переключением раскладки в KDE

Старожил


Сообщения: 335
Благодарности: 0

Профиль | Сайт | Отправить PM | Цитировать


У меня KDE говорит, что он изменил раскладку, а сам продолжает выводить только русский текст. Отключение языка не помогает (только если перезапустить Иксы). И что тут делать? Скажите, плиз.

-------
Спасибо за внимание
Slackware и LFS...


Отправлено: 01:06, 01-06-2003

 

Аватара для ruslandh

info man howto


Сообщения: 6949
Благодарности: 383

Профиль | Сайт | Отправить PM | Цитировать


Какой дистрибутив и какая версия XFree86 используется ?
Есть-ли переключение в других оконных менеджерах ?

-------
Поспешай не торопясь


Отправлено: 01:43, 01-06-2003 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Аватара для Belansky

Юниксоид


Сообщения: 3001
Благодарности: 45

Профиль | Отправить PM | Цитировать


Есть такая глюкавость в KDE. Я вообще не пользуюсь средствами KDE  для переключения раскладки клавиатуры. А индикатором служит лампочка Scroll Lock.

-------
Косово je Србиjа!


Отправлено: 08:03, 01-06-2003 | #3


Старожил


Сообщения: 335
Благодарности: 0

Профиль | Сайт | Отправить PM | Цитировать


ruslandh
Дистрибутив Slackware 9.0 (kernel 2.4.20), XFree86 4.3.0, KDE 3.1
Belansky
А как же тогда переключать раскладку???

-------
Спасибо за внимание
Slackware и LFS...


Отправлено: 19:42, 01-06-2003 | #4


Аватара для Belansky

Юниксоид


Сообщения: 3001
Благодарности: 45

Профиль | Отправить PM | Цитировать


Цитата:
А как же тогда переключать раскладку???
Так это в файле /etc/X11/XF86Config-4 прописано в секции:
Section "InputDevice"
   Identifier "Keyboard1"
   Driver "Keyboard"
   Option "XkbModel" "pc105"
   Option "XkbLayout" "us,ru(winkeys)"
   Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection
Вот в строке "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll" это и прописано, а  grp_led:scroll отвечает за индикацию переключения раскладки клавиатуры.

-------
Косово je Србиjа!


Отправлено: 21:43, 01-06-2003 | #5


Старожил


Сообщения: 335
Благодарности: 0

Профиль | Сайт | Отправить PM | Цитировать


Belansky
Thanx. Буду пробовать.

-------
Спасибо за внимание
Slackware и LFS...


Отправлено: 22:15, 01-06-2003 | #6


Аватара для ruslandh

info man howto


Сообщения: 6949
Благодарности: 383

Профиль | Сайт | Отправить PM | Цитировать


Другой выриант для XFree86 v 4.3

**********************************************************************
# Keyboard section
# **********************************************************************

Section "InputDevice"

   Identifier "Keyboard1"
   Driver      "Keyboard"
   Option "AutoRepeat"  "250 30"

   Option "XkbRules" "xfree86"
   Option "XkbModel" "pc105"
   Option "XkbLayout" "us,ru"
   Option "XkbVariant"  ",winkeys"
   Option "XkbOptions"  "grp:ctrl_shift_toggle,grp_led:scroll"

EndSection

-------
Поспешай не торопясь


Отправлено: 22:35, 01-06-2003 | #7


Старожил


Сообщения: 335
Благодарности: 0

Профиль | Сайт | Отправить PM | Цитировать


Belansky
ruslandh
Я сделал так:

Section "InputDevice"

  Identifier "Keyboard1"
  Driver      "Keyboard"
  Option "AutoRepeat"  "250 30"

  Option "XkbRules" "xfree86"
  Option "XkbModel" "pc104"
  Option "XkbLayout" "us,ru(winkeys)"  
  Option "XkbOptions"  "grp:alt_shift_toggle,grp_led:scroll"

EndSection

Но почему-то всё равно не работает. Что мне делать с настройками KDE после установок XFree86Config, и надо ли вообще что-нибудь там делать?

-------
Спасибо за внимание
Slackware и LFS...


Отправлено: 01:25, 02-06-2003 | #8


Аватара для ruslandh

info man howto


Сообщения: 6949
Благодарности: 383

Профиль | Сайт | Отправить PM | Цитировать


Sean Ingumsky
C настройками KDE делать ничего не надо (ну если только отключить их).
А вот настройку клавиатуры вообще проверить стоит. (переключение должно быть одинаковым во всех оконных менеджерах и и совпадать с переключением в терминале.)

Посмотри еще здесь :

http://forum.oszone.net/topic.cgi?fo...amp;topic=1246

-------
Поспешай не торопясь


Отправлено: 07:42, 02-06-2003 | #9


Аватара для Belansky

Юниксоид


Сообщения: 3001
Благодарности: 45

Профиль | Отправить PM | Цитировать


Sean Ingumsky
В том-то и дело, что настроив переключение раскладки клавиатуры приведенным выше способом, использовать переключатель KDE необходимости уже нет. Нужно только его отключить в Панели управления KDE. А само переключение должно работать одинаково во всех окнах и приложениях.

-------
Косово je Србиjа!


Отправлено: 09:13, 02-06-2003 | #10



Компьютерный форум OSzone.net » Linux и FreeBSD » Общий по Linux » Глюки с переключением раскладки в KDE

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Разное - [решено] Не отключается Caps Lock, проблема с переключением раскладки Amstel Microsoft Windows Vista 8 08-11-2016 14:13
Разное - [решено] проблемма с переключением раскладки на winXP64 Stereoflip Microsoft Windows 2000/XP 6 04-08-2009 00:35
Разное - Проблема с переключением раскладки клавиатуры JJKey Microsoft Windows 2000/XP 27 08-12-2008 21:02
Проблема с переключением раскладки Skriva Microsoft Windows NT/2000/2003 3 28-06-2006 13:53
Смена раскладки клавиатуры в KDE mixa_mixa Общий по Linux 12 23-09-2005 11:03




 
Переход