Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Клиентские ОС Microsoft » Microsoft Windows 2000/XP » Разное - [решено] Без видимых причин explorer.exe грузит процессор на 90-100%

Ответить
Настройки темы
Разное - [решено] Без видимых причин explorer.exe грузит процессор на 90-100%

Аватара для Aquana

Пользователь


Сообщения: 62
Благодарности: 1

Профиль | Отправить PM | Цитировать


Провела выделенку, поставила лицензионного Касперского Personal (версия 5.0). Обычно при входе в сеть запускаю TMeter (считает трафик), Ares (качаю фильмы) и ReGet, где тоже есть 5-6 активных закачек. Параллельно лажу по сайтам, смотрю видео, слушаю музыку.
При включении комп работает нормально, ничего не тормозит. Примерно через 20 минут появляются страшные тормоза. Смотрю: explorer.exe грузит проц почти на 100%, и память жрется в неимоверных количествах (доходило до 430 мег). Отключаю все работающие проги, оставляю только винды. Загрузка проца сохраняется. Работать на компе становится невозможно. Помогает только перезагрузка, через положенное время тормоза возвращаются. Но ведь не буду же я перезагружаться по нескольку раз за вечер!
Все, что находит Каспер (а он много находит), удаляю. Может быть это и не вирус вовсе, а железо слабое? А может Арес подвешивает (много недокачанных файлов висит)?
Мой комп: Пентиум4, 2.4, память 512, винт 80 гиг (свободных около 5 всего), видео 9200SE 128 мег.
Это сообщение посчитали полезным следующие участники:

Отправлено: 16:37, 10-08-2005

 

Аватара для Aquana

Пользователь


Сообщения: 62
Благодарности: 1

Профиль | Отправить PM | Цитировать


Сама и отвечаю. Кажется, проблему удалось локализовать и почти искоренить. Проверила систему Adaware Personal, выловила 13 Alexa, почистила, потом WinASO прошлась по реестру, прореперила, сейчас уже работаю более часа и никаких тормозов, разве что от Каспера, но я и так памяти добавить собиралась.
Вывод: надо чистить реестр от всякой дряни.

Отправлено: 22:10, 10-08-2005 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.



Administrator


Сообщения: 25152
Благодарности: 3798

Профиль | Сайт | Отправить PM | Цитировать


Цитата:
Вывод: надо чистить реестр от всякой дряни.
Вывод номер два: можно попробовать поискать темы с подобным вопросом, аналогичный вопрос уже задавался на форуме. Можно (и нужно) воспользоваться фильтрами по названию темы по explorer.

Результат


Так же стОит обращать внимание на объявления раздела, например:
Основные принципы размещения и поиска информации на конференции OSZone.net

-------
FAQ по Windows 10 .::. Настройка Центра обновления в Windows 10 .::. Чистая установка Windows 10 – пошаговая инструкция


Отправлено: 08:48, 11-08-2005 | #3


Аватара для Aquana

Пользователь


Сообщения: 62
Благодарности: 1

Профиль | Отправить PM | Цитировать


Цитата:
Вывод номер два: можно попробовать поискать темы с подобным вопросом, аналогичный вопрос уже задавался на форуме.
Задавался, но безрезультатно.
http://forum.oszone.net/showthread.php?t=7262

Цитата:
Можно (и нужно) воспользоваться фильтрами по названию темы по explorer.
Дело в том, что при таком задании поиска половина выбранных тем касается вопросов интернет эксплорера. Я искала "explorer.exe".

Цитата:
Так же стОит обращать внимание на объявления раздела, например:
И в названии вышеупомянутой темы проблема не уточняется, а именуется коротко: "проблема". Моя тема уточняет формулировку проблемы: "Без видимых причин explorer.exe грузит процессор на 90-100%".





-------
Проц: AMD Athlon 3500+
Мать: ASUS A8V Deluxe <Socket939, VIA K8T800Pro, DDR, AGP8x, Sound, SATA RAID, GB Lan, 1394, Ret
Память: 1024 (2 х Corsair VS512MB400 512 Mb)
Винт: 160.0 Gb Seagate ST3160023А Baracuda 7200.7 <7200, 8Mb>"
Сидюк: NEC DVD-RW 3500
Кулеры: Termaltake Big Typhoon (CPU), Zalman (корпус).


Отправлено: 13:54, 11-08-2005 | #4



Administrator


Сообщения: 25152
Благодарности: 3798

Профиль | Сайт | Отправить PM | Цитировать


Цитата:
Дело в том, что при таком задании поиска половина выбранных тем касается вопросов интернет эксплорера
Ну и что? Вторая половина касается именно проблемы с explorer.exe и практически в каждой давались рекомендации провериться на вирусы/трояны/spyware.
Цитата:
И в названии вышеупомянутой темы проблема не уточняется, а именуется коротко
Вы считаете, что это повод создавать новую тему с таким же вопросом? В таком случае вам не помешало бы ознакомиться с правилами конференции в целом и раздела в частности.
Я дал вам рекомендации по поиску информации на форуме и по созданию новых тем, а вы начинаете безпредметный спор типа кто прав, а кто не очень... детский сад.

-------
FAQ по Windows 10 .::. Настройка Центра обновления в Windows 10 .::. Чистая установка Windows 10 – пошаговая инструкция

Это сообщение посчитали полезным следующие участники:

Отправлено: 08:23, 12-08-2005 | #5


(*.*)


Сообщения: 36489
Благодарности: 6675

Профиль | Сайт | Отправить PM | Цитировать


Aquana
Фильтровать нужно по 100

-------
Канал Windows 11, etc | Чат @winsiders


Отправлено: 08:34, 12-08-2005 | #6


Новый участник


Сообщения: 7
Благодарности: 4

Профиль | Отправить PM | Цитировать


Столкнулся с аналогичной проблемой и сумел ее решить. Долго искал в интернете подсказки, однако столкнулся с тем, что многие люди жаловались на похожие проблемы и никто так решения и не нашел. Решил написать именно в этот топик, поскольку симптоматика с первым постом практически идентичная, а также в силу того, что он легко напрямую находится Гуглем. Возможно, мой опыт кому-то поможет. Постараюсь изложить так, чтобы новичку имеющему "соображалку", :-) желание и некоторый опыт было понятно как в принципе решаются такие проблемы.

Получилось так:
Стоит у меня XP - уже более года. Все было настроено, и работало нормально.
Непосредственно перед появлением проблем комп работал непрерывно более 2х суток.
За это время было установлено много различного софта и я развлекался с различными твиками непосредственно через правку реестра. В процессе "опытов" пробовал свои старые твики, оставшиеся в наследство еще от Win95. Среди прочего создавал в QuickLaunchBar и StartMenu (как для %UserName%, так и для AllUsers) папки типа:
Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D}
My Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
и еще кучу разных CLSID нарытых в реестре. (Кто не знает зачем это нужно - воспользуйтесь Гуглем :-))
Потом, в процессе дальнейших опытов я об этом забыл. Далее работал с реестром - машина работала нормально. В определенный момент мне понадобилась перезагрузка. Вот после перезагрузки и началось... Через 2-3 минуты работы заметил, что "постзагрузочное притормаживание" :-) несколько затянулось..., а через 10 минут работать стало практически невозможно. TaskManager показал что Explorer.exe дает загрузку проца от 20% до 100% и она непрерывно скачет (большей частью вокруг 90%). Кроме того он "кушал память" как карьерный экскаватор и через 10 минут зажрал более 600Мб памяти (из 768 возможных :-)), после чего "самоперезагрузился" (в смысле только Explorer.exe) и начал все заново.
Первая мысль - сел вирус (причем именно вирус, поскольку трояны обычно порождают собственный процесс, даже если он и скрыт). Осмотр Explorer.exe ничего не дал - код файла выглядел нормально, подозрительных блоков не наблюдалось, дата/время создания - стандартные. Долго рассказывать - провозился пол часа - вирусов не нашел.
Вторая мысль - какой-то софт поменял таки системные DLL - запустил SFC Check - ничего не дало.
Третья мысль - что-то попорол в реестре - хотя я знал что делаю и попороть теоретически ничего не мог. Попытался запустить System Restore - Единственная точка оказалась создана как раз во время последней перезагрузки :-) - выругался на собственную жадность, поскольку сам поставил предел для Restore Data в 100Мб. Вспомнить все что менял в реестре не представлялось возможным - менял много и был уверен, что все безопасно, особо и не запоминал, а кроме того - что там установленный софт наменял? - я вообще не знал.
Оставался единственный вариант - у меня было несколько резервных копий реестра сделанных вручную (т.е. простым копированием файлов) - последняя полугодовалой давности. Возвращаться к реестру полугодовалой давности мне не особенно хотелось, однако это давало шанс разобраться в проблеме.
Загрузил Win98 (с установленным NTFS for Win98 v4.01 Pro), распаковал бакап. _Забакапил_свой_"подпорченный"_реестр._ Попробовал для начала заменить ветку CurrentUser (Documents and Settings\%UserName%\ntuser.*) - перезагрузил XP - нет эффекта. Заметил и поубирал вышеупомянутые папки "CLSID" - так сказать "для чистоты эксперимента" (надо же как интуиция работает) - опять же значения особого этому не придал. Тогда решил поменять ветку LM\Software (Windows\system32\config\software.*) - Перезагрузил Win98, поменял Software.*, перезагрузил XP - и... возрадовался - ибо все заработало нормально. Далее чтобы свести "потери" к минимуму идея состояла в следующем:
Экспортировать из "нормального" (т.е. того с которым проблема не проявляется) реестра все ветки которые теоретически могут отвечать за проблемы с эксплорером идя сверху вниз по принципу сужения, а затем заменить реестр на "испорченный" и импортировать в него сохраненные .REG файлы с заведомо "правильными" установками, уже снизу вверх по принципу расширения.
Итак, загрузил RegEdit и последовательно экспортировал ветки:

1. [HKEY_LOCAL_MACHINE\SOFTWARE\] - На всякий случай. Больше брать просто бессмысленно поскольку, как мы помним, все заработало после замены software.* . Может пригодиться чтобы не перегружаясь что-то там потом вручную найти и импортировать если не поможет ветка 2.

2. [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows] - Если потом придется импортировать ее, но после этого все заработает, то пострадают только настройки программ Windows, остальной софт останется цел.

3. [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] - эта ветка, очевидно, отвечает за Эксплорер, а потому, если импортировать только ее и после этого все заработает - то мы теряем только настройки эксплорера (и то не все, а лишь те их изменения, что были сделаны за последние пол года) - по сути - мизер.

Перезагружаюсь в Win98, возвращаю "подпорченный" реестр из бакапа на место и перегружаюсь обратно в XP. И что бы вы думали...? - Все работает нормально! Удивление сменяется непониманием. Непонимание - раздумиями :-) - Через пару минут вспоминаю про удаленные папки "CLSID". Создаю их заново - все работает нормально (в том числе и "CLSID :-)). Перегружаюсь - пошли тормоза, или говоря культурно, начинаются проблемы с Explorer.exe. Удаляю папки снова, перегружаюсь - все работает отлично... - Выводы делайте сами :-) Чем ему эти папки помешали...? Только зря пол дня времени потерял...

Однако в других случаях причина может быть другая и очень часто всякого рода глюки и зависания связаны как раз с ошибками в реестре. Так что делайте резервные копии реестра хоть изредка, хоть раз в год :-) Можно это делать "руками", можно спец. программами. Ну а как выйти из неприятного положения с минимальными потерями - вы теперь знаете. :-)
Это сообщение посчитали полезным следующие участники:

Отправлено: 00:29, 30-09-2006 | #7



Administrator


Сообщения: 25152
Благодарности: 3798

Профиль | Сайт | Отправить PM | Цитировать


TheDrive
Спасибо за ваш отчет, возможно кому-то он пригодится. Правда больше все-таки похоже на частный случай и повинна была какая-то из устанавливаемых вами программ которая прописала в CLSID нечто настолько не понравившееся shell`у; и тем не менее это направление в котором стОит пробовать искать причину проблемы.
просьба: не обращайте внимания на пост sandycrazy и не отвечайте на него, это видимо не лечится...

-------
FAQ по Windows 10 .::. Настройка Центра обновления в Windows 10 .::. Чистая установка Windows 10 – пошаговая инструкция


Отправлено: 02:30, 30-09-2006 | #8


Новый участник


Сообщения: 8
Благодарности: 0

Профиль | Отправить PM | Цитировать


Здравствуйте! Недавно возникла похожая проблема. При открытии "Проводника" или любой папки по ярлыку с рабочего стола окно проводника загружается достаточно долго (20-25с.) при этом процесс explorer.exe (в частности тред browseui.dll) загружает процессор на ~50%. Пробовал заменять файл explorer.exe на другой - не помогло. Проверка на вирусы - KIS-2010 и AVZ не нашли ничего подозрительного.
Резервных копий реестра не делал, восстановление системы отключено.
Думаю попробовать импортировать [HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] из другой системы в которой нет таких глюков но я не знаю точно как это сделать.
Прошу помогите с решением этого глюка. Систему переустанавливать не очень хочется.
Конфигурация ПК:
MB: Gigabyte GA-EX38-DS5
CPU: IP4HT 3.2GHz
Memory: 2x Corsair XMS2, 2GB, 1066MHz
Video: ATI x1600 Pro, 256MB
HDD: Seagate 320GB, SATA2; Samsung 120GB, SATA1 (Система установлена на Seagate)

-------
Я всегда говорю правду! Даже тогда, когда вру...©Tony Montana - Scarface.


Отправлено: 17:01, 04-11-2009 | #9



Moderator


Сообщения: 53169
Благодарности: 15429

Профиль | Отправить PM | Цитировать


Martyr, попробуйте с помощью ShellExView отключать сторонние (не Microsoft) элементы (правой кнопкой мыши -> Disable Selected Items), в первую очередь типа Browser Helper Object.
Если не поможет, включите обратно.
Это сообщение посчитали полезным следующие участники:

Отправлено: 17:14, 04-11-2009 | #10



Компьютерный форум OSzone.net » Клиентские ОС Microsoft » Microsoft Windows 2000/XP » Разное - [решено] Без видимых причин explorer.exe грузит процессор на 90-100%

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Замедление работы системы без видимых причин Doom77 Непонятные проблемы с Железом 43 20-02-2010 01:24
Переодические зависания ПК без видимых причин rica Непонятные проблемы с Железом 4 20-09-2009 21:06
BSOD - Компьютер перезагружается без видимых причин!! Lumin@ry Непонятные проблемы с Железом 18 19-10-2008 03:18
машина тормозит без видимых причин rolton Непонятные проблемы с Железом 10 16-04-2008 13:34
[решено] после запуска фильмов explorer.exe загружает процессор до 100% starl Microsoft Windows 2000/XP 3 21-11-2006 11:17




 
Переход