Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Linux и FreeBSD » Общий по Linux » Debian/Ubuntu - [решено] монтирование дисков автоматом

Ответить
Настройки темы
Debian/Ubuntu - [решено] монтирование дисков автоматом

Аватара для Shurikss123

Пользователь


Сообщения: 98
Благодарности: 8

Профиль | Отправить PM | Цитировать


Привет господа, тут у меня маленький вопрос по поводу Ubuntu 8.10
Так как я переехал на линукс очень срочно еще не во всем разобрался, подскажите плиз как можно сделать так чтоб разделы fat ntfs автоматом монтировались при загрузки системы, а то я устал на них тыкать постоянно.

заранеее спасибо!!!

Отправлено: 10:43, 18-03-2009

 

Аватара для BuGfiX

Слакофил


Сообщения: 590
Благодарности: 130

Профиль | Сайт | Отправить PM | Цитировать


Испокон времен за монтирование в линуксах отвечает файл /etc/fstab, посмотрите на опцию auto команды mount.

-------
If you don`t know what to use this for, you don`t need it.

http://sergey.sereda.googlepages.com...e1_userbar.gif

Это сообщение посчитали полезным следующие участники:

Отправлено: 11:31, 18-03-2009 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Аватара для Shurikss123

Пользователь


Сообщения: 98
Благодарности: 8

Профиль | Отправить PM | Цитировать


Странно что за опция така?

Код: Выделить весь код
shurik@shurik-desktop:~$ mount -help
Usage: mount -V                 : print version
       mount -h                 : print this help
       mount                    : list mounted filesystems
       mount -l                 : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
       mount device             : mount device at the known place
       mount directory          : mount known device here
       mount -t type dev dir    : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
One can change the type of mount containing the directory dir:
       mount --make-shared dir
       mount --make-slave dir
       mount --make-private dir
       mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
       mount --make-rshared dir
       mount --make-rslave dir
       mount --make-rprivate dir
       mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using  -L label  or by uuid, using  -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say  man 8 mount .
а fstab что-то страшновато мне редактировать!!

Отправлено: 11:48, 18-03-2009 | #3


Новый участник


Сообщения: 32
Благодарности: 6

Профиль | Отправить PM | Цитировать


опция что-то вроде mount -a
Код: Выделить весь код
-a     Mount all filesystems (of the given types) mentioned in fstab.
auto   Can be mounted with the -a option.
набери в консоли man mount. А вообще, чего боишься-то?
Это сообщение посчитали полезным следующие участники:

Отправлено: 12:16, 18-03-2009 | #4


Аватара для Shurikss123

Пользователь


Сообщения: 98
Благодарности: 8

Профиль | Отправить PM | Цитировать


усе сделал, помог еще и пакет mountmanager. теперь все супер

Еще раз спасибо!!!!

Отправлено: 12:41, 18-03-2009 | #5


Аватара для NordWest

Старожил


Сообщения: 280
Благодарности: 1

Профиль | Отправить PM | Цитировать


А вот у меня возникла проблема на ту же тему.
Установил на ноут Debian 5.0 и не смог автоматом подключить внешний usb-диск. При его втыкании пишет, что мол правов у меня нету. Удается только из под рута командой mount делать. Что за права то он у меня требует, мне пользователя нужно в какую-то группу включить?

Отправлено: 18:43, 28-06-2009 | #6


Старожил


Сообщения: 267
Благодарности: 64

Профиль | Отправить PM | Цитировать


2 NordWest:
-что конкретно пишет насчет прав (у меня Debian 4.0 и никогда проблем с флэшками не возникало)
-если при подключении USB-носителя в /etc/fstab он появляется (например как /media/usbdisk или
/media/disk1), тогда попробуйте такое:
Код: Выделить весь код
sudo chmod 777 /media/usbdisk
если не появляется, то монтируете из под root'а вручную и выполняете вышеприведенную команду (соответственно указываете вашу точку монтирования)

Отправлено: 19:50, 28-06-2009 | #7


Аватара для [mzd]

Линуксоид-стакановец


Сообщения: 2394
Благодарности: 186

Профиль | Сайт | Отправить PM | Цитировать


NordWest, добавьте пользователя в группу plugdev, и проблемы с правами уйдут.

-------
Микроблог
Живя в реальном мире, стремись к невероятному... Эрнесто Че Гевара
Everybody lies. (c) House M.D.
Базовая настройка Ubuntu. Документация для новичка.
Руководство по установке, начальной настройке и основам использования операционной системы Ubuntu

Это сообщение посчитали полезным следующие участники:

Отправлено: 19:59, 28-06-2009 | #8


Аватара для NordWest

Старожил


Сообщения: 280
Благодарности: 1

Профиль | Отправить PM | Цитировать


Eakdrazile. Нет, права на папку я дал. Пишет, что именно монтировать у меня прав нет. У меня и в Debian 5.0 не возникало на домашнем компе, а тут на ноуте вдруг возникло.

[mzd], спасибо, попробую.

Отправлено: 07:37, 29-06-2009 | #9


Аватара для NordWest

Старожил


Сообщения: 280
Благодарности: 1

Профиль | Отправить PM | Цитировать


[mzd], что-то нет у меня такой группы. powerdev только, но включение в неё проблемы не решает.

А ошибка выдается такая:
Цитата:
Не удалось подключить том "Case"
ntfs-3g-mount: mount failed: Операция не позволяется . User doesn't have privilege to mount. For more information please see http://ntfs-3g.org/support#unprivilege
Это выскакивает при такого вида строке:
Цитата:
/dev/sda1 /media/sda1 ntfs-3g user,uid=1000,auto,locale=ru_RU.UTF-8 0 0
Если пробовать не ntfs-3g а ntfs прописывать, то пишет по другому, но примерно то же самое.
По ссылке ходил, мало что понял, но команды выполнил - результата не дало.

Такая команда монтирует диск из под рута, но у пользователя нет привилегий даже для просмотра содержимого, что и сообщается при попытке запустит обозреватель:
Цитата:
mount -t ntfs /dev/sda1 /media/sda1
Если:
Цитата:
mount -t ntfs-3g /dev/sda1 /media/sda1
, то опять ругань про привилегии с отсылкой на сайт...

Последний раз редактировалось NordWest, 29-06-2009 в 10:41.


Отправлено: 10:30, 29-06-2009 | #10



Компьютерный форум OSzone.net » Linux и FreeBSD » Общий по Linux » Debian/Ubuntu - [решено] монтирование дисков автоматом

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Монтирование дисков zippi Microsoft Windows NT/2000/2003 18 12-06-2007 10:03
Автоматическое монтирование дисков Artla_ Общий по Linux 1 24-03-2007 23:07
Монтирование сетевых дисков nsergeip Общий по Linux 35 22-03-2007 21:06
Монтирование дисков с NTFS5 в RH9 NSF Общий по Linux 9 13-02-2005 02:12
Монтирование виндовых дисков.. Guest Общий по Linux 8 18-03-2004 13:44




 
Переход