Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 2000/XP/2003 » [решено] Замеченная проблема с кодировкой telnet /?

Ответить
Настройки темы
[решено] Замеченная проблема с кодировкой telnet /?

Аватара для Grunger86

Ветеран


Сообщения: 1170
Благодарности: 99

Профиль | Отправить PM | Цитировать


Народ, скажите - у кого при запуске следующей команды (из cmd):
Код: Выделить весь код
telnet /?
отображается корявая кодировка, вида:
telnet [-a][-e 'Ё┐ўR<][-f "*c<_ўеR¤*][-l ?┐п][-t 'ЁЇ]["§?< [?Rав]]
-l "Є*§лў*?в Ё┐п ЇR<м§Rў*в?<п ¤<п ўлЇR<-?-Ёп ўеR¤* ў г¤*<?--го бЁбв?┐г
ЇаЁ гб<RўЁЁ, звR -* -?c ЇR¤¤?а│Ёў*?вбп Ї*а*┐?ва TELNET ENVIRON.
-a ?RЇлвЄ* *ўвR┐*вЁз?бЄR?R ўеR¤* ў бЁбв?┐г. 'R │?, звR Ё Є<оз -l,
-R ЁбЇR<м§г?в в?Єгй?? Ё┐п ЇR<м§Rў*в?<п, ЇR¤ ЄRвRал┐ ўлЇR<-?-
в?ЄгйЁc ўеR¤ ў бЁбв?┐г.
-e '<г│?Ў-лc бЁ┐ўR< Ї?а?Є<оз?-Ёп а?│Ё┐* ўўR¤* ў RЄ-? telnet-Є<Ё?-в*.
-f ?┐п д*c<* бR бвRаR-л Є<Ё?-в* ¤<п ўлЇR<-?-Ёп ўеR¤* ў бЁбв?┐г.
-t "Є*§лў*?в вЁЇ telnet-в?а┐Ё-*<*.
?R¤¤?а│Ёў*овбп вR<мЄR 4 вЁЇ* в?а┐Ё-*<Rў: vt100, vt52, ansi Ё vtnt.
"§?< "Є*§лў*?в Ё┐п г§<* Ё<Ё IP-*¤а?б г¤*<?--R?R ЄR┐Їмов?а*,
Є ЄRвRаR┐г ўлЇR<-п?вбп ЇR¤Є<оз?-Ё?.
?Rав "Є*§лў*?в -R┐?а ЇRав* Ё<Ё Ё┐п б<г│Ўл.

С чем это может быть связано и как устранить проблему? Есть опасения что такой рамс с кодировкой присутствует не только здесь.

Отправлено: 13:18, 21-05-2007

 

Аватара для qeraser

Старожил


Сообщения: 387
Благодарности: 40

Профиль | Отправить PM | Цитировать


Grunger86
У меня тоже самое. Первый раз такое вижу.

Отправлено: 17:56, 21-05-2007 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Старожил


Сообщения: 187
Благодарности: 28

Профиль | Отправить PM | Цитировать


Grunger86
Странно. У меня тоже так

Отправлено: 18:09, 21-05-2007 | #3

vek vek вне форума

Аватара для vek

Старожил


Сообщения: 400
Благодарности: 52

Профиль | Сайт | Отправить PM | Цитировать


Grunger86
Аналогично.

-------
Addon: RegShot


Отправлено: 08:46, 22-05-2007 | #4


Ветеран


Сообщения: 895
Благодарности: 137

Профиль | Отправить PM | Цитировать


выполни в cmd перед telnet /? такую команду
mode con cp select=1251 и буте тебе счастье
Это ошибка локализации.
В консоли по умолчанию стоит 866 кодировка, а в программе текст набран в 1251.

Отправлено: 10:17, 22-05-2007 | #5


Аватара для Grunger86

Ветеран


Сообщения: 1170
Благодарности: 99

Профиль | Отправить PM | Цитировать


дык как исправлять будем? может какой-то патч из апдейтпака косячит локализацию или что еще? вроде в нормальной винде не должно быть такого

-------
Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!


Отправлено: 13:36, 22-05-2007 | #6


(*.*)


Administrator


Сообщения: 34561
Благодарности: 6054

Профиль | Сайт | Отправить PM | Цитировать


Grunger86
После интеграции чего?

-------
Канал Windows 10, etc | Чат @winsiders


Отправлено: 19:32, 22-05-2007 | #7


Ветеран


Сообщения: 831
Благодарности: 50

Профиль | Отправить PM | Цитировать


У меня нечто подобное было при кривой теме VistaXP. Причем при размере шрифта 120dpi. Лечил переключением в 96 и обратно в 120. Шаманство, но помогало!

Отправлено: 22:26, 22-05-2007 | #8


Ветеран


Сообщения: 895
Благодарности: 137

Профиль | Отправить PM | Цитировать


Grunger86
Цитата:
может какой-то патч из апдейтпака косячит локализацию или что еще?
Возьми тотал коммандер.
открой файл telnet.exe в листере. Установи просмотр Unicode (6) и режим отображения ASCII (DOS charset). затем выполни поиск строки "-a".
пролистай на пол экрана к концу файла и поиграйся переходами между дос/виндовс кодировками. Часть файла в дос кодировки, часть в windows.

Открой файл tftp.exe в другом окне листера. Установи просмотр Unicode (6) и режим отображения ANSI (Windows charset). Затем выполни поиск строки "-i". и поиграйся переходами между дос/виндовс кодировками.

Мой вывод это проблема telnet.exe а не винды. Нужно поистить багрепорт в M$. пускай фиксят.
Это сообщение посчитали полезным следующие участники:

Отправлено: 10:46, 23-05-2007 | #9


Аватара для Grunger86

Ветеран


Сообщения: 1170
Благодарности: 99

Профиль | Отправить PM | Цитировать


такой глюк на всех виндах, в которых проинтегрирован апдейтпак
ну да, в telnet.exe кодировка в хелпе ASCII а в tftp.exe ANSI, виндовая
да и вообще там версия телнета какая-то новая, за 2005 год. может какой-то неофициальный патч из апдейтпака т.о. косячит кодировку или что-то в этом духе? или просто попробовать поставить туда более старую версию, должен же быть года эдак 2002...

-------
Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!


Отправлено: 22:51, 24-05-2007 | #10



Компьютерный форум OSzone.net » Автоматическая установка Windows » Автоматическая установка Windows 2000/XP/2003 » [решено] Замеченная проблема с кодировкой telnet /?

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Интерфейс - [решено] Проблема с кодировкой при импорте закладок jorikello Microsoft Windows 2000/XP 2 30-10-2008 10:51
[решено] Проблема с кодировкой в Блокноте D_Master Хочу все знать 5 09-09-2008 09:07
Ошибка - Странная проблема с кодировкой(похоже проблема с преобразованием кодировок) Mertvii Microsoft Windows 2000/XP 1 13-07-2008 16:05
[решено] Проблема с кодировкой во время установки Urbanrasta Автоматическая установка Windows 2000/XP/2003 2 09-06-2007 01:39
[Решено] Проблема с кодировкой кириллицы в консольном FTP-клиенте FunkyByte Microsoft Windows 2000/XP 2 17-05-2006 00:37




 
Переход