Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Linux и FreeBSD » Программное обеспечение Linux и FreeBSD » Проблемы с установкой mplayer

Ответить
Настройки темы
Проблемы с установкой mplayer

Пользователь


Сообщения: 143
Благодарности: 2

Профиль | Отправить PM | Цитировать


У меня дистр ASPLinux 11.2.
собрался установить mplayer, скачал RPM-ы с их официального ftp:

1) mplayer-1.0-0.20.pre8.2.112asp.i386.rpm
2) mplayer-docs-1.0-0.20.pre8.2.112asp.i386.rpm
3) mplayer-fonts-1.1-3.110asp.noarch.rpm

Поставил сначала 2) потом 3), и начал ставить 1) и мне система выдает:

lidirectfb-0.9.so.24 необходимо для mplayer-1.0-0.20.pre8.2.112asp.i386.rpm
liblzo.so.1 необходимо для mplayer-1.0-0.20.pre8.2.112asp.i386.rpm
libopenal.so.0 необходимо для mplayer-1.0-0.20.pre8.2.112asp.i386.rpm

Что это означает ? и как с этим бороться ?

Отправлено: 20:13, 12-01-2007

 

Аватара для [mzd]

Линуксоид-стакановец


Сообщения: 2394
Благодарности: 186

Профиль | Сайт | Отправить PM | Цитировать


Дайте команду
Код: Выделить весь код
yum install mplayer
Она все зависимости разрешит и что надо доставит.

-------
Микроблог
Живя в реальном мире, стремись к невероятному... Эрнесто Че Гевара
Everybody lies. (c) House M.D.
Базовая настройка Ubuntu. Документация для новичка.
Руководство по установке, начальной настройке и основам использования операционной системы Ubuntu


Отправлено: 21:34, 12-01-2007 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Аватара для ruslandh

info man howto


Moderator


Сообщения: 6949
Благодарности: 383

Профиль | Сайт | Отправить PM | Цитировать


Исходя из этого списка (что требуется mplayer)
http://rpmseek.com/rpm/mplayer-1.0-0...:0:0:0:1450336
Что-то из этого списка :
gtk+-devel
SDL-devel
libpng-devel
lame-devel
libogg-devel
libvorbis-devel
libmad
desktop-file-utils
alsa-lib-devel
aalib-devel
lirc
cdparanoia-devel
libdv-devel
arts-devel
xvidcore-static
esound-devel
libdvdread-devel
faad2-devel
lzo-devel
libfame-devel
rpmlib

PS Надеюсь rpm для ASP ?

-------
Поспешай не торопясь


Отправлено: 09:56, 13-01-2007 | #3


Пользователь


Сообщения: 143
Благодарности: 2

Профиль | Отправить PM | Цитировать


ruslandh
Цитата:
Надеюсь rpm для ASP ?
Да. и взял я их с ftp ASPLinux'а.
Цитата:
gtk+-devel
SDL-devel
libpng-devel
lame-devel
libogg-devel
libvorbis-devel
libmad
desktop-file-utils
alsa-lib-devel
aalib-devel
lirc
cdparanoia-devel
libdv-devel
arts-devel
xvidcore-static
esound-devel
libdvdread-devel
faad2-devel
lzo-devel
libfame-devel
rpmlib
Интересно, все это должно входить rpm mplayer'а, или это надо все искать где-то на стороне ?
Как тогда правильней установить mplayer ?

Отправлено: 10:57, 13-01-2007 | #4


Аватара для must die

Ветеран


Сообщения: 715
Благодарности: 77

Профиль | Отправить PM | Цитировать


1Space

Весь этот список это отдельные пакеты, от которых зависит работа mplayer. Часть уже есть в вашем дистрибутиве, чего-то не хватает.
Для установки ПО в linux не надо применять подход из windows (скачал, установил). Воспользуйтесь пакетным менеджером, который входит в состав вашего дистрибутива
он сам все скачает и установит необходимые зависимости, все очень просто.



Цитата:
Дайте команду
Код:

yum install mplayer

Она все зависимости разрешит и что надо доставит.

-------
Вопреки популярному мнению, Unix - дружелюбная ОС.
Просто так случилось, что она очень избирательна в выборе друзей.


Отправлено: 14:28, 13-01-2007 | #5


Пользователь


Сообщения: 143
Благодарности: 2

Профиль | Отправить PM | Цитировать


Цитата:
Воспользуйтесь пакетным менеджером, который входит в состав вашего дистрибутива
он сам все скачает и установит необходимые зависимости, все очень просто.
имеется ввиду скачает из инета ? но у меня нет инета на ПК где Linux стоит

Отправлено: 16:03, 13-01-2007 | #6


Аватара для [mzd]

Линуксоид-стакановец


Сообщения: 2394
Благодарности: 186

Профиль | Сайт | Отправить PM | Цитировать


Он скажет, каких именно пакетов не хватает и где их можно скачать.

-------
Микроблог
Живя в реальном мире, стремись к невероятному... Эрнесто Че Гевара
Everybody lies. (c) House M.D.
Базовая настройка Ubuntu. Документация для новичка.
Руководство по установке, начальной настройке и основам использования операционной системы Ubuntu


Отправлено: 16:52, 13-01-2007 | #7



Компьютерный форум OSzone.net » Linux и FreeBSD » Программное обеспечение Linux и FreeBSD » Проблемы с установкой mplayer

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Проблемы с установкой ХР Wonka Автоматическая установка Windows 2000/XP/2003 5 24-09-2008 18:59
ALTLinux - Проблемы с установкой Ilya7 Общий по Linux 3 18-07-2008 07:28
Проблемы с xmms и mplayer radioamator Программное обеспечение Linux и FreeBSD 14 04-12-2003 11:41
MPlayer - проблемы SSS Программное обеспечение Linux и FreeBSD 11 13-10-2003 14:20
Проблемы с установкой. Parik Сетевые технологии 2 31-08-2003 17:49




 
Переход