Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Linux и FreeBSD » Программное обеспечение Linux и FreeBSD » upgrade Apache from 1.3.31 to 1.3.37

Ответить
Настройки темы
upgrade Apache from 1.3.31 to 1.3.37
habud


Сообщения: n/a

Профиль | Цитировать


Есть Linux сервер. На нем из исходников установлен Apache 1.3.31. Я скачал исходники 1.3.37, чтобы обновить. Можно ли просто поставить 1.3.37 поверх старого таким образом:

$ ./configure --prefix=/path/to/old/apache
$ make
$ make install

Как ставился предыдущий Апач никто уже не знает.

PS пишу второй раз, первый раз сессия экспирировалась (или IP поменялся) - и всё пропало.

Отправлено: 15:03, 24-09-2006

 

Аватара для ruslandh

info man howto


Сообщения: 6949
Благодарности: 383

Профиль | Сайт | Отправить PM | Цитировать


Что за дистрибутив у вас установлен ?

Я - бы так не рискнул, лучше собрать RPM по спеку от старого Apache, сохранить все настройки старого Apache, а потом уже ставить из rpm.

-------
Поспешай не торопясь


Отправлено: 17:08, 24-09-2006 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.

habud


Сообщения: n/a

Профиль | Цитировать


> Что за дистрибутив у вас установлен ?

Slackware

Кстати, старые исходники, конечно же, тоже остались. Может выцепить старую конфигурацию из них?

Отправлено: 18:16, 24-09-2006 | #3


Аватара для ruslandh

info man howto


Сообщения: 6949
Благодарности: 383

Профиль | Сайт | Отправить PM | Цитировать


Я не силён в Slackware и не знаю есть-ли там что-то аналогичное spec файлам (в rpm дистрибутивах).

-------
Поспешай не торопясь


Отправлено: 18:30, 24-09-2006 | #4


Пользователь


Сообщения: 137
Благодарности: 18

Профиль | Отправить PM | Цитировать


во фряхе make install не затирает старые конфиги. скорее всего так же и в слаке.

Отправлено: 20:18, 24-09-2006 | #5


Аватара для BuGfiX

Слакофил


Сообщения: 590
Благодарности: 130

Профиль | Сайт | Отправить PM | Цитировать


habud, сделайте так:
Код: Выделить весь код
ls -l /var/log/packages | grep apache
если в результате получите что-то типа
Код: Выделить весь код
-rs-r--r-- 1 root root 24416 2006-08-15 22:07 apache-1.3.31-i486-1
то apache у вас установлен из пакетов слаки. Удалить его можно командой
Код: Выделить весь код
removepkg apache
Если же выведется другая версия апача, либо вообще ничего, тогда остается разве что руками удалить все его файлы.
Насчет установки:
1 вариант:
Собираете из исходников, но вместо make install делаете make DESTDIR=/tmp/apache install. Далее переходите в каталог /tmp/apache и делаете makepkg apache-1.3.37.tgz. Полученный файл устанавливаете с помощью installpkg.
2 вариант:
Качаете (или берете с диска) slackbuild для apache, изменяете нужным вам образом, и запускаете. В результате получится все тот же самый tgz.

Отправлено: 21:05, 24-09-2006 | #6

habud


Сообщения: n/a

Профиль | Цитировать


С удалением файлов проблем особых нет - Апач никуда кроме пути, указанного в префиксе, файлы не складывает. И папку с конфигурацией тоже не трогает (в случае наличия оной). Проблема в том, чтобы собрать новый Апач таким же, каким была собрана предыдущая версия.

2 BuGfiX
Нет, Апач был установлен вручную, из исходников.

> Насчет установки:...

А чем перечисленные варианты будут принципиально отличаться от "$ make install"?

Отправлено: 23:27, 24-09-2006 | #7


Аватара для BuGfiX

Слакофил


Сообщения: 590
Благодарности: 130

Профиль | Сайт | Отправить PM | Цитировать


Цитата:
А чем перечисленные варианты будут принципиально отличаться от "$ make install"?
тем что если устанавливаете что-дибо в дистрибутив (неважно какой), лучше руководствоваться правилами дистрибутива, т.е. его менеджера пакетов. Если сделаете как я советовал - сможете в любой момент удалить пакет нормальным путем с помощю removepkg, а не rm
Это сообщение посчитали полезным следующие участники:

Отправлено: 00:00, 25-09-2006 | #8



Компьютерный форум OSzone.net » Linux и FreeBSD » Программное обеспечение Linux и FreeBSD » upgrade Apache from 1.3.31 to 1.3.37

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Upgrade XP to Vista?.. mvch1970 Microsoft Windows Vista 2 07-01-2007 22:09
Upgrade WinNt4.0 до Windows2003Server dimsa Microsoft Windows NT/2000/2003 1 13-12-2006 14:25
Windows XP Professional Upgrade Timofeyster Автоматическая установка Windows 2000/XP/2003 1 27-07-2006 12:54
Upgrade TX97-E bgg0408 Непонятные проблемы с Железом 19 03-09-2003 00:38




 
Переход