Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Клиентские ОС Microsoft » Microsoft Windows 8 и 8.1 » Разное - Не устанавливается или не запускается программа от имени администратора

Ответить
Настройки темы
Разное - Не устанавливается или не запускается программа от имени администратора

Новый участник


Сообщения: 33
Благодарности: 3


Конфигурация

Профиль | Отправить PM | Цитировать


Есть windows 8.1 Enterprise original x86 en + русский MUI. Есть две учетные записи Microsoft: одна с правами администратора, другая с обычными правами. Антивирус и файрвол родные. sfc /scannow ошибок не находит. Из стороннего софта только 7z и mtorrent. UAC включен. Вирусов нет, система чистая.
Проблема в следующем: работа ведется из под учетки обычного пользователя. Перестали запускаться программы требующие права администратора. Ранее программа требующие права админа выдавала запрос на ввод пароля и после успешного ввода запускала нужную утилиту. Спустя некоторое время запуск срабатывал через раз. Т.е. чтобы запустить например установку программы с первого раза после ввода пароля ничего не происходило, после повторной попытки со второго или третьего раза запуск происходил. Спустя некоторое время все функции требующие ввода пароля админа перестали работать. Вернее выдается запрос на ввод пароля, ввожу правильный пароль и... ничего не происходит.
Поиск в инете дал такое решение: включить встроенную запись администратора. Решение работает, НО:
1. Хочу понять, что произошло?
2. Решить вопрос, отключив встроенную запись администратора. Ведь раньше работало.
Надеюсь на помощь в решении вопроса. Какие будут идеи и предложения?

Отправлено: 00:19, 27-12-2013

 


Moderator


Сообщения: 51454
Благодарности: 14747

Профиль | Отправить PM | Цитировать


spispi, приведите ошибки из журнала событий -> Журналы Windows -> в разделах Приложение и Система (правой кнопкой мыши -> Копировать -> Копировать сведения как текст).

Попробуйте рекомендации
Как определить, является проблема системной или вызвана сторонним приложением/службой

Цитата:
Вернее выдается запрос на ввод пароля, ввожу правильный пароль и... ничего не происходит
Сделайте лог Process Monitor следующим образом:
  1. запустите Process Monitor;
  2. попытайтесь запустить какую-либо программу от имени администратора, чтобы ничего не произошло;
  3. сохраните лог: меню File -> Save -> PML-формат;
  4. заархивируйте и выложите на любой файлообменник, например http://rghost.ru

Отправлено: 07:34, 27-12-2013 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Новый участник


Сообщения: 33
Благодарности: 3

Профиль | Отправить PM | Цитировать


Цитата Petya V4sechkin:
spispi, приведите ошибки из журнала событий -> Журналы Windows -> в разделах Приложение и Система (правой кнопкой мыши -> Копировать -> Копировать сведения как текст). »
Ошибок нет, хотя журналы ведутся.

Цитата Petya V4sechkin:
Попробуйте рекомендации
Как определить, является проблема системной или вызвана сторонним приложением/службой »
Пробовал. В защищенном режиме с правами с правами обычного пользователя все отрабатывает как надо. С совсеми отключенными элементами автозагрузки (один относится к тачпад и два к wi-fi) и службами не Microsoft (одна относится к видеокарте вторая к HP сервису ноутбука) в обычном режиме с правами обычного пользователя - не работает. Подпись драйверов проверил - все подписаны.


Цитата Petya V4sechkin:
Цитата:
Сделайте лог Process Monitor следующим образом:запустите Process Monitor;попытайтесь запустить какую-либо программу от имени администратора, чтобы ничего не произошло;сохраните лог: меню File -> Save -> PML-формат;заархивируйте и выложите на любой файлообменник, например http://rghost.ru »
Не получается. Для запуска нужны права администратора.


Пробовал еще:

1. cоздал учетную запись "testwork" (не Microsoft, а локальную с правами обычного пользователя) ситуация такая же. Работа непосредственно из-под учетки "admsergey" (админа) проблем никаких не вызывает.

2. под учеткой обычного юзера c зажатым шыфтом правой кнопкой на софтину запустить от имени другого пользователя (затем ввожу логин и пароль админа) выдает следующее (пример):

===================

[Window Title]
C:\Users\ipad4_000\Downloads\ProcessMonitor\Procmon.exe
[Content]
Windows не удается получить доступ к указанному устройству, пути или файлу. Возможно, у вас нет нужных разрешений для доступа к этому объекту.
[ОК]

===================

3. сперва отключил учетку обычного юзера, затем перезагрузился и включил. Ситуация не изменилась.

Отправлено: 23:11, 27-12-2013 | #3



Moderator


Сообщения: 51454
Благодарности: 14747

Профиль | Отправить PM | Цитировать


spispi, выложите логи RSIT.
Это сообщение посчитали полезным следующие участники:

Отправлено: 11:29, 28-12-2013 | #4


Новый участник


Сообщения: 33
Благодарности: 3

Профиль | Отправить PM | Цитировать


Цитата Petya V4sechkin:
spispi, выложите логи RSIT. »
Любое приложение запускаемое из под обычной учетки и требующее прав админа - не отрабатывает (после ввода пароля ничего не происходит). Поэтому сделал так (не знаю верно это или нет): включил встроенную учетку админа и под учеткой обычного пользователя запустил RSIT. Эти логи в файле с именем rsit-RunUnderUser.7z
http://rghost.ru/51256965

Дополнительно запускал утилиту под учеткой созданного мной Администратора. Эти логи в файле с именем rsit-RunUnderAdm.7z

Отправлено: 13:12, 28-12-2013 | #5



Moderator


Сообщения: 51454
Благодарности: 14747

Профиль | Отправить PM | Цитировать


Цитата spispi:
Подпись драйверов проверил - все подписаны
У этих драйверов:
Код: Выделить весь код
R3 atikmdag;atikmdag; C:\Windows\system32\DRIVERS\atikmdag.sys [2008-12-01 4179968]
R3 GTIPCI21;GTIPCI21; C:\Windows\system32\DRIVERS\gtipci21.sys [2006-04-07 88192]
R3 NETw2v32;@oem4.inf,%NIC_Service_DispName_BG_VISTA%;Intel(R) PRO/Wireless 2200BG Network Connection Driver for Windows Vista; C:\Windows\system32\DRIVERS\NETw2v32.sys [2007-03-07 2595840]
R3 SMSCIRDA;@oem1.inf,%SMCIRDA.ServiceDesc%;SMSC Infrared Device Driver; C:\Windows\system32\DRIVERS\SMSCirda.sys [2007-04-25 31232]
R3 smwdm;smwdm; C:\Windows\system32\drivers\smwdm.sys [2005-03-29 220992]
R3 SynTP;@oem2.inf,%SynTP.SvcDesc%;Synaptics TouchPad Driver; C:\Windows\system32\DRIVERS\SynTP.sys [2007-09-15 191408]
R3 tifm21;tifm21; C:\Windows\system32\drivers\tifm21.sys [2006-07-06 168448]
цифровой подписи быть не может: дата задолго до релиза Windows 8.1 (и даже до Windows 7, если на то пошло).

Отправлено: 13:30, 28-12-2013 | #6


Новый участник


Сообщения: 33
Благодарности: 3

Профиль | Отправить PM | Цитировать


Цитата Petya V4sechkin:
У этих драйверов:
Код:
R3 atikmdag;atikmdag; C:\Windows\system32\DRIVERS\atikmdag.sys [2008-12-01 4179968]
R3 GTIPCI21;GTIPCI21; C:\Windows\system32\DRIVERS\gtipci21.sys [2006-04-07 88192]
R3 NETw2v32;@oem4.inf,%NIC_Service_DispName_BG_VISTA%;Intel(R) PRO/Wireless 2200BG Network Connection Driver for Windows Vista; C:\Windows\system32\DRIVERS\NETw2v32.sys [2007-03-07 2595840]
R3 SMSCIRDA;@oem1.inf,%SMCIRDA.ServiceDesc%;SMSC Infrared Device Driver; C:\Windows\system32\DRIVERS\SMSCirda.sys [2007-04-25 31232]
R3 smwdm;smwdm; C:\Windows\system32\drivers\smwdm.sys [2005-03-29 220992]
R3 SynTP;@oem2.inf,%SynTP.SvcDesc%;Synaptics TouchPad Driver; C:\Windows\system32\DRIVERS\SynTP.sys [2007-09-15 191408]
R3 tifm21;tifm21; C:\Windows\system32\drivers\tifm21.sys [2006-07-06 168448]
цифровой подписи быть не может: дата задолго до релиза Windows 8.1 (и даже до Windows 7, если на то пошло). »
Тогда у меня возникает еще 2 вопроса:

1. Для проверки подписи я запускал sigverif. Вот лог его работы:
http://rghost.ru/51258293
Везде стоит подписано. Отсюда у меня и вопросы: либо я что-то не так делаю для проверки подписи, либо я что-то не так интерпретирую, либо я чего-то не понимаю? Можно этот момент прояснить?

2. Момент второй. Я попробовал отключить эти драйвера через autoruns и перезагрузился. Результат не изменился. Правильно ли я сделал или нужно было пробовать делать как-то по другому?

Отправлено: 14:15, 28-12-2013 | #7



Moderator


Сообщения: 51454
Благодарности: 14747

Профиль | Отправить PM | Цитировать


Цитата Petya V4sechkin:
Сделайте лог Process Monitor следующим образом
Цитата spispi:
Не получается. Для запуска нужны права администратора.
Запустите через runas, например:
Код: Выделить весь код
runas /user:имя_пользователя C:\procmon\procmon.exe
Цитата spispi:
Отсюда у меня и вопросы: либо я что-то не так делаю для проверки подписи, либо я что-то не так интерпретирую, либо я чего-то не понимаю? Можно этот момент прояснить?
Не знаю, почему sigverif считает их нормальными.
Если у драйвера цифровая подпись для Vista или XP, нет никакой гарантии совместимости с Windows 8.1.

Отправлено: 15:35, 28-12-2013 | #8


Новый участник


Сообщения: 33
Благодарности: 3

Профиль | Отправить PM | Цитировать


Цитата Petya V4sechkin:
Запустите через runas, например:
Код:
runas /user:имя_пользователя C:\procmon\procmon.exe »
Тоже не запускает. Я под админом дал полный доступ на procmon.exe обычному пользователю - только после этого запустилось.

Сейчас перезалью файл.

Пробовал запускать cmd.exe c правами администратора. И еще пробовал запускать на установку файл install.exe c подмонтированного iso.

Последний раз редактировалось spispi, 28-12-2013 в 23:33.


Отправлено: 23:28, 28-12-2013 | #9


Новый участник


Сообщения: 33
Благодарности: 3

Профиль | Отправить PM | Цитировать


Цитата spispi:
Сейчас перезалью файл. »
Вот файл:
http://rghost.ru/51270929

Цитата spispi:
Пробовал запускать cmd.exe c правами администратора. И еще пробовал запускать на установку файл install.exe c подмонтированного iso. »
Пробовал запускать cmd.exe c правами администратора. И еще пробовал запускать на установку файл g:\setup.exe c подмонтированного iso содержащего оригинальный дистрибутив visio. Причем, что странно, начиная с этого момента:

=========================
Date & Time: 28.12.2013 22:37:31
Event Class: File System
Operation: CreateFile
Result: PATH NOT FOUND
Path: G:\ui\SwDRM.dll
TID: 5688
Duration: 0.0000489
Desired Access: Read Attributes
Disposition: Open
Options: Open Reparse Point
Attributes: n/a
ShareMode: Read, Write, Delete
AllocationSize: n/a
=========================

Везде ниже где пишет PATH NOT FOUND и пытается создать файлы на диске G: - какой-то бред. Я такие файлы первый раз в глаза вижу да и какого лешего он там пытается что-то создавать.

Отправлено: 00:04, 29-12-2013 | #10



Компьютерный форум OSzone.net » Клиентские ОС Microsoft » Microsoft Windows 8 и 8.1 » Разное - Не устанавливается или не запускается программа от имени администратора

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
Доступ - Программа запускается только от имени администратора linkwy Microsoft Windows 7 7 20-10-2013 01:26
Прочее - Программа не видит сетевой диск при запуске от имени администратора urch Сетевые технологии 1 06-09-2013 16:53
Доступ - Не удается запустить программу не от имени администратора parkone Microsoft Windows 8 и 8.1 9 18-01-2013 12:30
2008 R2 - Настроить, чтобы программа всегда выполнялась от имени администратора uProwest Windows Server 2008/2008 R2 1 11-01-2011 11:23
Разное - Outlook запускается только от имени администратора 3pi Microsoft Windows Vista 1 25-10-2007 21:04




 
Переход