Имя пользователя:
Пароль:  
Помощь | Регистрация | Забыли пароль?  | Правила  

Компьютерный форум OSzone.net » Linux и FreeBSD » Общий по FreeBSD » FreeBSD - [решено] Apache22 не запускается при старте системы

Ответить
Настройки темы
FreeBSD - [решено] Apache22 не запускается при старте системы

Пользователь


Сообщения: 67
Благодарности: 0

Профиль | Отправить PM | Цитировать


У меня в файле /etc/rc.conf прописана строка
Код: Выделить весь код
apache_enable="YES"
но при старте системы апаче не запускается как быть?

А при запуске (# /usr/local/sbin/apachectl start ) запускается, но пишет:

Код: Выделить весь код
 [warn] (2)No sach file or directory: Failed to enable the `httppready` Accept Filter

Отправлено: 02:06, 04-08-2008

 

Новый участник


Сообщения: 17
Благодарности: 2

Профиль | Отправить PM | Цитировать


apache22_enable="YES", если не ошибаюсь

и

http://www.mydigitallife.info/2006/0...-filter-error/
Это сообщение посчитали полезным следующие участники:

Отправлено: 08:09, 04-08-2008 | #2



Для отключения данного рекламного блока вам необходимо зарегистрироваться или войти с учетной записью социальной сети.

Если же вы забыли свой пароль на форуме, то воспользуйтесь данной ссылкой для восстановления пароля.


Пользователь


Сообщения: 67
Благодарности: 0

Профиль | Отправить PM | Цитировать


Gnix,
не совсем понял из http://www.mydigitallife.info/2006/0...-filter-error/

выходит надо добавить строку в /boot/loader.conf:

Код: Выделить весь код
accf_http_load=”YES”
но чтот не катит.
Что не так делаю?

Отправлено: 09:20, 04-08-2008 | #3


Пользователь


Сообщения: 92
Благодарности: 2

Профиль | Отправить PM | Цитировать


Он у тебя на запускается только при страте системы ?
Или вообще не запускается ?

/usr/local/etc/rc.d/apache22 start - что говорит ?
(apache22_enable="YES")

Отправлено: 19:55, 04-08-2008 | #4


Аватара для dmitryst

Штатный телепат


Сообщения: 5220
Благодарности: 540

Профиль | Сайт | Отправить PM | Цитировать


_soldat_, httpd -S что выдаёт? Конфиг нормальный?

-------
Осваиваю FreeBSD


Отправлено: 21:58, 04-08-2008 | #5


Пользователь


Сообщения: 67
Благодарности: 0

Профиль | Отправить PM | Цитировать


dmitryst,
Цитата dmitryst:
httpd -S что выдаёт? Конфиг нормальный? »

Код: Выделить весь код
httpd -S

Virtual Host configuration:
192.168.2.247:80       is a NameVirtualHost
                 default server example.com (/usr/local/etc/apache22/httpd-vhosts.conf :27)
                 port 80 namevhost example.com (/usr/local/etc/apache22/httpd-vhosts.conf :27)
Syntax OK

Последний раз редактировалось _soldat_, 05-08-2008 в 01:44.


Отправлено: 01:25, 05-08-2008 | #6


Пользователь


Сообщения: 67
Благодарности: 0

Профиль | Отправить PM | Цитировать


С автозапуском все норма, но вот если запускать в ручную



А при запуске (# /usr/local/sbin/apachectl start ) запускается, но пишет:

Код: Выделить весь код
 [warn] (2)No sach file or directory: Failed to enable the `httppready` Accept Filter

Отправлено: 03:26, 06-08-2008 | #7


Аватара для dmitryst

Штатный телепат


Сообщения: 5220
Благодарности: 540

Профиль | Сайт | Отправить PM | Цитировать


Цитата _soldat_:
А при запуске (# /usr/local/sbin/apachectl start ) запускается, но пишет: »
ну и фиг с ним... У меня то же самое пишет, но работает. Пока отложил разборки до лучших времен.

Так... Нашел!

Цитата:
это изза accf_http модуля..
kldload accf_http - решит проблему...
+постоянно пропиши эту ***ню в /boot/loader.conf
добавь accf_http_load=”YES”

-------
Осваиваю FreeBSD


Последний раз редактировалось dmitryst, 09-09-2008 в 17:11.

Это сообщение посчитали полезным следующие участники:

Отправлено: 11:36, 06-08-2008 | #8


Новый участник


Сообщения: 6
Благодарности: 0

Профиль | Отправить PM | Цитировать


Столкнулся с такой же проблемой: Apache 2.2.11 не хочет запускаться при старте системы.
В /etc/rc.conf прописал apache22_enable="YES" - все равно не хочет.
Директория, в которую установлен сервер - /usr/local/apache22/. Вручную, при введении команды /usr/local/apache22/bin/apachectl start, все прекрасно работает.
В чем же здесь причина?

Отправлено: 12:33, 29-01-2009 | #9


Аватара для bozordzh

Старожил


Сообщения: 316
Благодарности: 41

Профиль | Сайт | Отправить PM | Цитировать


LevshinO, тогда в /usr/local/etc/rc.d запихай скриптик типа :
#!/bin/sh
/usr/local/apache22/bin/apachectl start

Отправлено: 15:03, 29-01-2009 | #10



Компьютерный форум OSzone.net » Linux и FreeBSD » Общий по FreeBSD » FreeBSD - [решено] Apache22 не запускается при старте системы

Участник сейчас на форуме Участник сейчас на форуме Участник вне форума Участник вне форума Автор темы Автор темы Шапка темы Сообщение прикреплено

Похожие темы
Название темы Автор Информация о форуме Ответов Последнее сообщение
[решено] Автоподключение ADSL при старте системы infallible Microsoft Windows Vista 10 29-01-2010 07:54
Разное - При старте системы кулер взлетает matios Прочее железо 4 15-04-2009 16:45
Разное - [решено] Запуск при старте системы+доступ к интерфейсу Delion Soulblade Microsoft Windows 2000/XP 4 25-03-2008 12:07
Win2003 подключение по PPTP при старте системы DeathMoroz Microsoft Windows NT/2000/2003 5 14-01-2008 10:06
[решено] Уровень громкости звука при старте системы ivieDVeD Microsoft Windows 2000/XP 6 08-12-2005 22:47




 
Переход