Компьютерный форум OSzone.net  

Компьютерный форум OSzone.net (http://forum.oszone.net/index.php)
-   Общий по Linux (http://forum.oszone.net/forumdisplay.php?f=9)
-   -   Горячие клавиши!!!! (http://forum.oszone.net/showthread.php?t=13108)

Guest 02-03-2004 18:01 70171

Люди!!! Как переключить раскладку клавиатуры с клавиатуры..!  

JeweL 02-03-2004 18:28 70172

http://ruslandh.h1.ru/howto_ru/Cyril...ian/index.html

ruslandh 02-03-2004 20:57 70173

Guest
А какую раскладку Вы выбрали при установке ? Какой дистрибутив, хотя-бы, если не помните.

Guest 03-03-2004 07:00 70174

ruslandh   У меня стоит Красная Шапочка 9/  По умолчанию раскладка английска/  Чтоб пререключиться на русский приходится залазить в Системные настройки  Привычные горячие клавиши не работают Чувствую себя идиотом.  

Petya 03-03-2004 08:17 70175

Guest
я для себя эту проблему решил вот так .... правда у меня слака 9.1 уже ...



/home/(user_name)/.kde/share/config

файл    kxkbrc


[Layout]
Additional=ru
AdditionalEncodings=KOI8-R
Encoding=ISO8859-1
Layout=us,ru(winkeys)
Model=pc105
Options=grp:alt_shift_toggle,grp_led:scroll
ResetOldOptions=false
SwitchMode=WinClass
Use=true
Variants=ru(winkeys)

ruslandh 03-03-2004 08:50 70176

1 Petya - я подозреваю, что это будет работать только в KDE
2 Guest - а почему-бо Вам не поставить какую-нибудь русскую раскладку ?
http://www.linux-ink.ru:8080/Russian...ify.html#ruskb
http://www.linux-ink.ru:8080/Russian/Docs/russify.html
http://www.linux-ink.ru:8080/Russian...kbdconfig.html


Добавлено:

раскладка в RedHat меняется командой redhat-configure-keyboard (если я не ошибся в написании команды).

Guest 03-03-2004 13:35 70177

Огромное всем спасибо!
Все оказалось гораздо проще:)

Petya 03-03-2004 19:08 70178

Guest
Цитата:

Огромное всем спасибо!
Все оказалось гораздо проще
это как ? сказать слабо ?

ruslandh 03-03-2004 19:58 70179

Guest
Опишит пожалуста как вы решили свою проблему, может ещё кому-то сгодится :)

Diesel 04-03-2004 13:10 70180

Проблема такая: в КДЕ раскладка переключается по Ctrl+Alt+K
С английской на русскую переключаю нормально, а обратно (с русской на английскую) - никак. Вероятно, дело в том что ПОСЛЕ переключения на русскую Ctrl+Alt+K на клавиатуре становится Ctrl+Alt+Л Кто-нить знает как бороться? В принципе, я вешал раскладку на нейтральную клавишу - Ctrl+Alt+1, все работает, но очень уж некрасиво. При установке системы тип клавиатуры указал ru. Может следовало указать ru-1251? Помогите, плз!

ruslandh 04-03-2004 20:21 70181

Diesel
А вы не используйте этот переключатель, используйте, если возможно (не знаю вашего дистрибутива) системный или что-нибудь типа xxkb

Diesel 05-03-2004 09:42 70182

Дистр Шапка 9 А системный переключатель - это тот который в чистой консоли юзается, Ctrl+Shift? Удобно, а в HOWTO описано, как его к КДЕ прикрутить?

Добавлено:

Прочитал в HOWTO насчет xkb
Мой конфиг:

Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "ru,us"
Option "XkbOption" "grp:shift-toggle,grp_led:scroll"

Но два Шифта не работают. Где грабли? Или КДЕшный переключатель перекрывает? Как бороться?

Petya 05-03-2004 10:05 70183

Diesel
Цитата:

Или КДЕшный переключатель перекрывает?
именно так =)
Цитата:

Как бороться?
смотреть что я написал выше - а именно
Цитата:

/home/(user_name)/.kde/share/config

файл    kxkbrc


[Layout]
Additional=ru
AdditionalEncodings=KOI8-R
Encoding=ISO8859-1
Layout=us,ru(winkeys)
Model=pc105
Options=grp:alt_shift_toggle,grp_led:scroll
ResetOldOptions=false
SwitchMode=WinClass
Use=true
Variants=ru(winkeys)
будет переключатся как в винде - через альт шифт и всё будет ок =) сам придумал и сам проверил и сам использую ... и с другими делюся ...


[s]Исправлено: Petya, 2:10 5-03-2004[/s]

Diesel 05-03-2004 12:50 70184

Petya Все НИШТЯК, работает! Однако индикатор языка в таскбаре кажет
"ru" для английского и ",ru" для русского - конечно это несущественно, но некрасиво. Не знаешь как лечить?

Guest 05-03-2004 13:53 70185


ruslandh

Прошу прощения. что не объяснил...
Просто по умолчанию стояла английская раскладка, которая ни как не реагировала ни на какую из известных комбинаций клавиш. *Но стоило переключиться *на русскую раскладку заработала комбинация из *Shift+ Shift :gigi:

mrco 05-03-2004 13:56 70186

Можно было паросто отключить КДЕ-шный переключатель и использовать только ХКВ правда в трее не будет отображаться текущая раскладка :-(

Diesel 05-03-2004 15:03 70187

Ну, а в КДЕ это можно как нибудь без багов сделать? Хочется все же привычные клавиши юзать, Ctrl+Shift, на худой конец Alt+Shift, и чтоб индикатор корректно изображался, потому как есть две проблемы:
1. Когда быстро набираешь текст и лишний раз переключишься, bltn djn nfrfz ,zrf, приходится вернуть курсор и перебить
2. А если (моя мечта, но может продавлю начальство) ставить юзерам RedHat 9  && OpenOffice, изнеженные подоконники таких траблов не потерпят:-(

ruslandh 05-03-2004 16:03 70188

Diesel
Так, я про xxkb говорил, это-же индикатор + ScrooLoock зажигается при русской раскладке.
Если речь идёт о RedHat, то там по-умолчанию рабочая среда Gnome (ну не любят в Америке KDE :) ) то для Gnome подойдёт GSwitchIt:
http://www.ruslandh.narod.ru/Linux-Chip/index.htm

Diesel 05-03-2004 16:11 70189

А где этот самый xxkb взять как поставить и как настроить?

ruslandh 05-03-2004 19:05 70190

http://netadmin1.ic.tsu.ru/other/xxkb/

Добавлено:

Кроме того этот пакет есть в дистрибутивах AltLinux и ASPLinux

Petya 05-03-2004 21:13 70191

Diesel
Цитата:

Все НИШТЯК, работает! Однако индикатор языка в таскбаре кажет
"ru" для английского и ",ru" для русского - конечно это несущественно, но некрасиво. Не знаешь как лечить?
к сожалению пока еще не разобрался - правда и не осбо разбирался .... в понедельник тлт раньше скажу точно - я пробовал там конфиг руками крутить - но он зараза почему то не хотел работать как хочу я ... всё время на дефолт сбрасывал ... ну в обещм поглядим :)

ЗЫ а скролллок (лампочка загорается) это юзеров не устраивает ? :(


Время: 00:54.

Время: 00:54.
© OSzone.net 2001-