Компьютерный форум OSzone.net  

Компьютерный форум OSzone.net (http://forum.oszone.net/index.php)
-   Железо в Linux (http://forum.oszone.net/forumdisplay.php?f=29)
-   -   ATI в Fedora Core 2 (решена) (http://forum.oszone.net/showthread.php?t=48606)

hasherfrog 26-04-2005 18:14 319388

ATI в Fedora Core 2 (решена)
 
Вложений: 3
Целый день потратил на попытку разрулить ситуацию. Ноль по фазе :[

В интернете огромное количество подобных вопросов, с решениями даже - у меня не работают.

Fedora Core 2 (2.6.5-1.358smp #1 SMP)
Драйвера с ati.com: fglrx_6_8_0-8.12.10-1

Сгенерённый xorg.conf - аттач
Лог Xorg.0.log - аттач
Результат scanpci - аттач

Кое-что уже наверняка понял, о чём речь, наверное :[
Не стартует X server, говоря, что
Цитата:

No matching Device section for instance (BusID PCI:4:0:1) found
Читал (наблюдал даже), что поменяв 4:0:1 на 4:0:0 - можно решить. В моём случае не выходит - ругается тогда на 4:0:0 (см. scanpci).

Есть идеи? Кроме как выкинуть fedora core-2? И переустановить двора на старое что-нибудь (типа fglrx-4.3.0-3.9.0) с параллельным патчением на ходу?

[added]
Для поисковика:
ATI Radeon X300

ruslandh 26-04-2005 21:44 319450

У вас какое-то несоответствия ядра и модуля fglrx. Насколько я помню, для fglrx нужен добавочный модуль ядра.

hasherfrog 27-04-2005 14:45 319666

В общем. я слышал, что можно поставить ATI от FC3 и типа всё будет работать.
Но я пошёл другим путём. Было интересно. Вот моё решение:

Скачиваем src.rpm для ATI:
http://rpm.livna.org/fedora/2/i386/S...vn.1.2.src.rpm
Кладём скачанный файл в /tmp/

При попытке установки обнаруживаем, что нужен интрумент fedora-rpmdevtools
Скачиваем:
ftp://rpmfind.net/linux/fedora/extra...-1.0-1.src.rpm
Кладём скачанный файл в /tmp/

#Становимся рутом.
#su

Строим необходимый инструментарий:
cd /tmp
rpmbuild --rebuild fedora-rpmdevtools-1.0-1.src.rpm

Результат компиляции упал в /usr/src/redhat/RPMS/noarch/
Устанавливаем его:
rpm -i /usr/src/redhat/RPMS/noarch/fedora-rpmdevtools-1.0-1.noarch.rpm

Теперь строим ATI-драйвера из исходников
cd /tmp
rpmbuild --rebuild --target i686 ati-fglrx-8.12.10.1-0.lvn.1.2.src.rpm

Результаты компиляции попадали в /usr/src/redhat/RPMS/i686/
Устанавливаем их:
cd /usr/src/redhat/RPMS/i686/
rpm -ihv ati-fglrx-8.12.10.1-0.lvn.1.2.i686.rpm
rpm -ihv ati-fglrx-devel-8.12.10.1-0.lvn.1.2.i686.rpm
rpm -Uhv kernel-module-fglrx-2.6.5-1.358smp-8.12.10.1-0.lvn.1.2.i686.rpm

#Сохраняем старый XF86Config-4
#cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.pre

Конфигурим
fglrxconfig

Теперь получился XF86Config-4 - а нам надо xorg.conf !!! Я был зол :[

Сохраняем старый xorg.conf
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.pre

Удаляем xorg.conf
rm /etc/X11/xorg.conf

Делаем ссылку (подменяем xorg.conf)
cd /etc/X11
ln -s XF86Config-4 xorg.conf

Клавиатура после конфигурации получилась неправильная.
Редактируем xorg.conf в части клавиатуры
Убираем:
Option "XkbRules" "xfree86"
Option "XkbModel" "pc101"
Option "XkbLayout" "ru"
Вставляем:
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru"
Option "XkbOptions" "grp:shift_toggle,grp_led:scroll"

Перегружаемся (полностью, не только X).

Проверка:
fglrxinfo
Должно быть "OpenGL vendor string: ATI Technologies Inc."


Возможно, что-то забыл :-Р
Возможно, что-то покажется кому-то глупостью.
Тем не менее - работает.
Всем удачи :]

hasherfrog 27-04-2005 14:54 319671

Кстати, думаю, после такой процедуры лучше не лазить в system-config-display :]


Время: 09:58.

Время: 09:58.
© OSzone.net 2001-