Компьютерный форум OSzone.net  

Компьютерный форум OSzone.net (http://forum.oszone.net/index.php)
-   Общий по Linux (http://forum.oszone.net/forumdisplay.php?f=9)
-   -   Ноут самопроизвольно включается... (http://forum.oszone.net/showthread.php?t=199778)

Grey_rnd 17-02-2011 19:52 1615611

Ноут самопроизвольно включается...
 
Здравствуйте!
Подскажите плз как справиться с этой напастью, после выключения ноута, через секунд 10-20 происходит автоматическое включение.
Ubuntu 10.10 и ноутбук AsusX59SL.
По просторам гугла уже прошелся...советуют отключить в биосе Wake on Lan, ноу меня такой фишки нет просто.
Параллельно установлена Win7, таких проблем нет.

ruslandh 18-02-2011 14:45 1616181

Так-как при включении никакая операционка не работает, то включать может только Bios

Grey_rnd 18-02-2011 15:26 1616225

ruslandh, Ну да я тоже это понимаю, но получается противоречие какое то. :sorry:
При выключении после win7, все нормально, а после выключения из lin происходит включение.... как такое могет быть? Должно же быть объяснение? Полтергейст какой то! Вечером напишу версию биос.
Я просто уже извелся блин.... :( Но, походу дела действительно зависит все от Lan, сегодня отключал модем, потом погасил ноут и все нормуль. Еще конечно проверю, мо ж случайность просто.

ruslandh 18-02-2011 16:01 1616266

Скорей всего Windows при выключении сбрасывает опцию bios на просыпание (от сети или модема), а Linux это не трогает.

Grey_rnd 18-02-2011 16:34 1616319

ruslandh, Мо ж в модеме просто отключить...или там как вообще организован процесс? Бук просыпается если приходят на порт пакеты? Или спец пакет какой? У меня HUAWEI SmartAX MT880.
Я вроде весь биос прошелестел на этот wake, нету...

ruslandh 18-02-2011 17:13 1616356

В биосе может быть какая-нибудь опция просыпания от сети, или от модема (называться может совершенно по-разному).
Обычно такая опция используется для несильно загруженных серверов - кто-то к нему обратился, он проснулся, никто не обращается - он опять спит.

Grey_rnd 18-02-2011 19:52 1616478

ruslandh, Нашел в bios опцию onboard lan boot rom. Описание тут probios, дело в том, что у меня Disabled. :(

ruslandh 18-02-2011 22:51 1616613

Это не про то - это загрузка по сети

Grey_rnd 19-02-2011 08:36 1616773

ruslandh, Ну да....не то.
Че то я ваще в ужасе, чем дальше в лес, тем толще партизаны... :o
Прошелся по просторам yandex, так вот пишуть:
Цитата:

Чтобы Wake on lan вообще работал - нужно сначала включить его в биосе, а потом уже в операционной системе.
Для просмотра настроек сетевого интерфейса в линуксе нужно установить утилиту ethtool и дать команду:
ethtool eth0. В результате получаем информацию об указанном сетевом интерфейсе, среди которой интересна лишь строка Wake-on: d.
Вот что выдаем у меня:
читать дальше »

grey_rnd@AsusX59SL:~$ sudo ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Current message level: 0x00000037 (55)
Link detected: yes

Т.е. у меня такой штуки нет в принципе. Чудеса, да и только... :shot:

P.S. Мо ж и не в софте дело то? Щас почитал, у многих такая весчь. Рассуждений на тему много, от неисправности БП и мамки, до помех в сети и прочего. Ну если было б было все так плохо, то я думаю, было бы в обоих случаях,независимо от ОС.

ruslandh 20-02-2011 12:08 1617511

Wake-on может быть и не при чём.

Grey_rnd 20-02-2011 18:50 1617808

ruslandh, :( и в каком направлении двигаться дальше? Замкнутый круг...
Я так понимаю, что тут еще acpi может быть завязан?
Покопался в инете еще, но нашел только подтверждение того, что немогет быть запуск по wakeonlan.
Установил acpitool. Вот че выдает по запросу:
читать дальше »

Код:

grey_rnd@AsusX59SL:~$ sudo acpitool -w
  Device        S-state          Status  Sysfs node
  ---------------------------------------
  1. PCI0          S4        disabled  no-bus:pci0000:00
  2. USB          S3        disabled  pci:0000:00:03.0
  3. USB2          S3        disabled  pci:0000:00:03.1
  4. HDA          S4        disabled  pci:0000:00:0f.0
  5. P0P6          S4        disabled  pci:0000:00:06.0
  6. P0P7          S4        disabled 
  7. EUSB          S3        disabled  pci:0000:00:03.3
  8. MAC          S4        disabled  pci:0000:00:04.0
  9. S184          S4        disabled  pci:0000:00:05.0
  10. PWRB          S4        *enabled 
  11. SLPB          S4        *enabled


Короче, убиться веником... :durak:

ruslandh 20-02-2011 20:30 1617879

Вообще-то должны использоваться правила udev

Grey_rnd 20-02-2011 21:00 1617898

ruslandh, Немного подробнее можна? Я в lin ландух полный... :(
Несовсем понял, причем тут udev?

licher 07-11-2014 19:33 2426212

имеется акер,кстановлена винда 8.1 и Кубунту( перед этим была убунту) та же самая беда,после выключения включается опять,если загрузиться с винды и выключить ноут с винды такого больше не наблюдается,так что как бы не говорили всякие умники что ОС здесь не при делах это бред, пробовал федору кнопих и им подобные такого не происходит,только с убунту такая беда


Время: 04:00.

Время: 04:00.
© OSzone.net 2001-